Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    session manager authentication problems

    I've recently installed FC5 on my AMD x86_64.
    I am working iwith VMD witch is a molecular visualization program that uses openGL (it use to work just fine on my FC4). Whenever I try to run it on the FC5 it seems to open for less than a second and then it quits. When I tried to run it as root I got this warning:

    Warning: Tried to connect to session manager, Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed

    Does anyone know how to fix this? I am assuming that it is a problem with the session manager rather than the program I am runnig but I am not sure.

    Thank you for you're help.


  2. #2
    anyone? please?
    Does anyone know what the problem is or have seen it before?

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Montreal, Canada
    Are you trying to run this program as root, or as a user?

    Anyway that only means that the program you are trying to launch doesn't have the autorization to connect to your current X session.

    Verify a few things:

    1) Are you able to login to a X session?

    2) Do you have this line in your /etc/network/interfaces:
    Code:  localhost.localdomain localhost
    3) Check the log of your login manager. If GDM, then
    cat /var/log/gdm/\:0.log
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. $spacer_open
  5. #4
    when I log in as user or root the program just won't run - it will just seem to opent for a sec and close. when I logon as user and go to super user mode it gives the warning as above.

    I do have the local host lione in my config file.

    my gdm log reads:
    X Window System Version 7.0.0
    Release Date: 21 December 2005
    X Protocol Version 11, Revision 0, Release 7.0
    Build Operating System:Linux 2.6.9-22.18.bz155725.ELsmp x86_64Red Hat, Inc.
    Current Operating System: Linux localhost.localdomain 2.6.15-1.2054_FC5 #1 SMP Tue Mar 14 15:48:20 EST 2006 x86_64
    Build Date: 06 March 2006
    Before reporting problems, check
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue May 30 09:29:02 2006
    (==) Using config file: "/etc/X11/xorg.conf"
    SetGrabKeysState - disabled
    SetGrabKeysState - enabled
    SetGrabKeysState - disabled
    SetGrabKeysState - enabled

    Any suggestions?


  6. #5
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    I have deleted several other threads that asked this same question. Do not ask the same question in more than one section of the forum.
    Registered Linux user #270181

  7. #6
    Just Joined!
    Join Date
    Apr 2008
    I had the same problem and then installed libstdc++5 and it worked!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts