Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Grub, LVM and multi-boot problem

    I have an HP workstation with 3 SCSI drives, with FC4 installed to the first drive (sd0), FreeBSD 6.0 on the second (sd1) and recently installed FC5 to the third (sd2) which was previously unused (no partitions). I'm having problems to boot into FC5 after installation, it seems to be related to a possible Grub configuration issue and LVM's. FC5 was installed from DVD media, with typical settings, nothing special. I was not offered any configuration for Grub during the install process, which I thought was odd. The install finished, and I rebooted. Grub loaded, but it appears to be the original Grub installed by FC4. I can boot into FC4 and FreeBSD no problem. I checked my grub.conf file, and nothing was added for booting FC5 from the third disk, only my original config was there. I attempted to add the lines to boot FC5, but I'm not at all familiar with LVM, and that appears to be causing my problems. My grub.cong is below. Note that I just guessed how it should look for booting FC5, I have been unable to find any information about this so far.

    title Fedora Core SMP (2.6.16-1.2111_FC4smp)
    root (hd0,0)
    kernel /vmlinuz-2.6.16-1.2111_FC4smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=force
    initrd /initrd-2.6.16-1.2111_FC4smp.img

    title Fedora Core UP (2.6.16-1.2111_FC4)
    root (hd0,0)
    kernel /vmlinuz-2.6.16-1.2111_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=force
    initrd /initrd-2.6.16-1.2111_FC4.img

    title FreeBSD
    rootnoverify (hd1,0)
    chainloader +1

    title Fedora Core 5
    root (hd2,0)
    kernel /vmlinuz-2.6.15-1.2054_FC5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=force
    initrd /initrd-2.6.15-1.2054_FC5.img

    If I select FC5 from the Grub boot menu, the boot message is:

    Booting 'Fedora Core 5'

    root (hd2,0)
    Filesystem type is ext2fs, partition type 0x83
    kernel /vmlinuz-2.6.15-1.2054_FC5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=force

    Error 15: File not found

    press any key to continue...

    I'm guessing here, but I think the problem lies with the LVM's and how they are specified in Grub.conf. Maybe Grub is trying to read from the wrong LVM, the one that is used by FC4, instead of the FC5 volume? I have never attempted to boot multiple Linux' before where each used LVM's, hence my lack of knowledge here. I'm far from a Linux newbie, but I'm definitely an LVM noob.

    What do I need to do to get Grub to boot my new FC5 installation? Do I just need to edit my Grub.conf, or (re)install Grub using the FC5 media, or what?

    FYI, no Windoze on this box, only *NIX.



  2. #2
    Update: Seems I had an error in my grub.conf, although my problem is still not solved. The corrected FC5 entry in my grub.conf is now:

    title Fedora Core 5
    root (hd2,0)
    kernel /vmlinuz-2.6.15-1.2054_FC5smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=force
    initrd /initrd-2.6.15-1.2054_FC5smp.img

    I forgot to add the "smp" to the kernel string and initrd string. I had copied that part of the grub.conf from my laptop which is already running FC5, but forgot about my workstation having dual CPU's and using the SMP kernel. After correcting this, I get a bit different, but expected result: It boots the FC5 kernel but mounts my FC4 LVM volume. So It appears my theory is correct about the LVM. How do I specifcy a different LVM in my grub.conf to be mounted by FC5, because obviously it is not rooting itself based on the disk name specified (hd2,0) and it is mounting the LVM volume from (hd0,0).

  3. #3
    bump... anyone?

  4. $spacer_open
  5. #4
    Found what appears to be your answer on a page.

    Try adding (hd2,0) before the root argument.


    kernel /vmlinuz-2.6.15-1.2054_FC5 ro root=(hd2,0)/dev/VolGroup00/LogVol00 rhgb quiet acpi=force

  6. #5
    Double-check your kernel. Are you sure it's not like this:



    I compared you're entry to the one in my grub loader and it is identical, except for the missing period there. Although I am running fedora 8 and it's .fc8. Here's my entry just in case it might help you:

    root (hd0,0)
    kernel /vmlinuz- ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    initrd /initrd-
    LOL, just noticed how old this thread was... Someone sent it to me, so I figured that it was recent. Sorry for the zombie post!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts