Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Post Not able to do updates of Fedora Core 3 using yum

    Dear friends
    I have installed Fedora core 3 on my system. i want to do the updates availabe for it. I tried with yum command. I was not able to do it successfully. i am hearwith attaching the error i got. i request you people to help me out.

    [root@linuxserver ~] # yum update

    You have enabled checking of packages via GPG keys. This is a good thing. However, you donot have any GPG public keys installed. You need to download the keys for packages you wish to install and install them.

    You can do that by giving the command :

    rpm - - import public.gpg.key

    For more information contact your distributor or package provider

    [root@linuxserver ~] # rpm - - import public.gpg.key
    error : public.gpg.key : import read faild.
    [root@linuxserver ~] #

    This is the exact error wht i am getting. pls help me out to get through.

    with regards Nidhin

  2. #2
    Hi nidhintomson,
    Run the following commands : -
    [root@linuxserver ~] # rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora
    [root@linuxserver ~] # rpm --import /usr/share/rhn/RPM-GPG-KEY
    Try running YUM after the above commands and post the results.

    With Regards,

  3. #3

    Post Not able to do Fedora core 3 updates using YUM command

    hi thinker

    Thanks for yuor reply. but it didnt work . i am getting the same error.

    error : rpm - - import /use/share/rhn/RPM-GPG-KEY-fedora: import read failed

    same error i am getting when i tried without fedora at the end too

    with regards


  4. $spacer_open
  5. #4
    Hi nidhintomson,
    Become root and run the following command : -

    rpm --import /usr/share/doc/fedora-release-3/RPM-GPG-KEY*
    If in case you cannot find files in /usr/share/doc/fedora-release-3/ in your current installation of Fedora Core 3, you can download the .rpm file from here : -

    and install it and then run the above mentioned command. Post the results after you have done this.

    With Regards,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts