If its a rhine card then it is supported. all you have to do is modprobe the correct module.. im not at home now so i cant check for you sorrry, something like "via_rhine".. will check back later.