Is your system a 64-bit one? I have had this issue when running in mixed mode (32-bit as well as 64-bit) and the plugin installed was the wrong one for the browser that was installed.