While upgrading Squeeze I came across an error saying that exim4-daemon-light package was in a very bad inconsistent state and that I should reinstall it before attempting a removal.
So I did just...