You'll need to define "Ubuntu 10.10, opensuse 11.3 gnome,Linux mint 10 did not run". Any errors or can you tell us what happens that makes you say it will not run?