The RAM you show would be a problem for many of the full distros suck as Ubuntu which requires a minimum of 512MB and recommends a gigabyte. Any Puppy derivative should work. Slitaz would but it is...