Yes you do need to download gcc, I recomend downloading gcc as a rpm and installing it that way.

To install a package:
rpm –ivh
ex. rpm -ivh somepackage.1.1-4.i386.rpm

replace the package...