That's not Fedora, that's Alsa that starts em muted. Try using alsamixer from the command line to check and make sure your mixer is setting volumes and all right. Also, try using alsaplayer to play...