your linux cd's kernel do not support your hardware, try another one version higher. recommand fedora 7 or higher.