FC3 CDs should have gcc RPMs.
Just have to install them.

Install them all as
#rpm -ivh gcc*.rpm
This should take care of the dependency problems.