Find the answer to your Linux question:
Results 1 to 2 of 2
While on the console, I am able to login and su - to root, as root, however, I try to access another machine on the network via ssh and given ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    mjc
    mjc is offline
    Just Joined!
    Join Date
    Jul 2007
    Posts
    21

    SSH = Permission Denied


    While on the console, I am able to login and su - to root, as root, however, I try to access another machine on the network via ssh and given a "Permission Denied" message"

    I also try ssh as user but still receive the Permission Denied (publicKey) message. Is there an ssh configuration entry that I can temporarily disable to allow me to gain access?

    Thanks in advance

  2. #2
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    712
    Most ssh servers disable root logins as a security precaution. It is better to login as a user and then su to root because that leaves an audit trail in the logs. To change it, check for the following line in /etc/ssh/sshd_config

    Code:
    PermitRootLogin no
    Change it to yes and restart sshd.

    For your other problem, it seems that the only authentication method available is public key. Check the sshd_config file again for

    Code:
    PasswordAuthentication no
    Change it to yes and restart sshd. If these don't help then post your sshd_config file here so we can take a peek.

    Let us know how you get on,

    Chris...
    To be good, you must first be bad. "Newbie" is a rank, not a slight.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •