Find the answer to your Linux question:
Results 1 to 2 of 2
Hey everyone! I just built a Linux box running Fedora 9 with an older PC I had lying around. I'm a PHP developper, so my intention is to run Apache, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    2

    [solved] fwbuilder with iptables help


    Hey everyone!

    I just built a Linux box running Fedora 9 with an older PC I had lying around. I'm a PHP developper, so my intention is to run Apache, PHP, MySQL, OpenVPN, Ventrilo and a few other things on there for personal use. I've been doing this with Windows for years, but I figured now's as good a time as any to dive into Linux.

    Anyhow, onto the problem -- I've got all my services running just fine, now I want to secure them. Keep in mind this is only a personal server, so it doesn't need to be air tight. I've been playing around with fwbuilder and have read quite a few tutorials on it, but I cannot seem to build a working firewall that doesn't block absolutely everything.

    Here's a screencap of a few rules I've created:



    This seems to block everything as soon as I install the firewall. What's odd is that even if I stop iptables at this point, it still blocks everything. I have to reboot the box to get it going again. I've also tried replacing "Firewall" with my server's actual IP in the rules, but that seems to produce the same results.

    Alot of confusion arises from the fact that since I'm running two instances of bridged OpenVPN (one with encryption, one without), I not only need a network bridge (br0) but tap0 and tap1 as well. Which do I set as "management interface"?

    I was wondering if anyone would be so kind as to give me a few example rules that apply to my configuration? Or if it's not the rules, but something else, give me a hand with that?!

    Many thanks in advance!

  2. #2
    Just Joined!
    Join Date
    Dec 2008
    Posts
    2
    Nevermind... Problem solved!

    I re-created all the rules from scratch, condensed a few rules into one, and it works perfectly! I'm not entirely sure what I did wrong the first time, but I'm not going to complain.

    I'm off to celebrate with family. Happy holidays!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •