Find the answer to your Linux question:
Results 1 to 5 of 5
i am trying to use ssh command from one linux box to another but it just don't work. root@app# ssh -v mars OpenSSH_3.1p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f debug1: Reading ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    9

    ssh not working


    i am trying to use ssh command from one linux box to another but it just don't work.

    root@app# ssh -v mars
    OpenSSH_3.1p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Rhosts Authentication disabled, originating port will not be trusted.
    debug1: restore_uid
    debug1: ssh_connect: getuid 0 geteuid 0 anon 1
    debug1: Connecting to mars [192.168.1.100] port 22.
    debug1: temporarily_use_uid: 0/0 (e=0)
    debug1: restore_uid
    debug1: temporarily_use_uid: 0/0 (e=0)
    ssh: connect to address 192.168.1.100 port 22: Connection timed out
    debug1: restore_uid

    Can anyone help??

  2. #2
    Linux Newbie zdawg's Avatar
    Join Date
    Jan 2004
    Location
    Canada
    Posts
    218
    Sshd is started on both boxen?
    Me & Myself just ganged up on I....... Now We all have problems..and none of Us are speaking!
    bash-3.00$ uname -a
    SunOS sparky 5.11 OpenSolaris-swa sun4u sparc SUNW,Ultra-Enterprise

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    9
    Yes, both ssh is running.

    I can use ssh to both boxes using putty port 22 but not ssh at command level.

  4. #4
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    most will not allow remote access as user root, and unless you specify a differnt user

    ssh qub333@linuxforums.org

    as opposed to

    ssh linuxforums.org

    you will get bumped. Also as a gneral rule, you shouldnt be root unless neciarry..
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  5. #5
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by qub333
    Also as a gneral rule, you shouldnt be root unless neciarry..
    I would actually *highly* suggest that you not allow root to login, as doing so is stupid. You can prohibit root login via the setting:

    Code:
    PermitRootLogin no
    in your /etc/ssh/sshd_config file.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •