Hi All ,

Facing some problems with the password authentication with public/private key pairs in linux. Actually I had set my keys and tey were working properly i.e., I was ale to login without being prompted for password/passphrase.
Yesterday, the linux box prompted me to change my password. I changed it, but from that time onwards my authentication is failing.

As a workaround, I had generated a new pair of keys and tried importing and trying them. But of no use. No matter where I generate (Windows/Linux), I am not able to resolve the issue. I strongly believe there is some problem related to my password, but unable to understand, where I am going wrong.

Actually I am trying to connect thru putty to an linux server. I have done what all has to be done.
1. Generated keys
2. Added the public key to authorization keys
3. put the private key to the peagent running on windows.

This is the output of the event log

================================================== ===
15:08:51 Looking up host "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.net"
15:08:54 Connecting to xxx.xxx.xxx.xxx port 22
15:08:55 Server version: SSH-1.99-OpenSSH_3.6.1p2
15:08:55 We claim version: SSH-2.0-PuTTY_Release_0.60
15:08:55 Using SSH protocol version 2
15:08:55 Doing Diffie-Hellman group exchange
15:08:55 Doing Diffie-Hellman key exchange with hash SHA-1
15:08:56 Host key fingerprint is:
15:08:56 ssh-rsa 1024 xxxx.............
15:08:56 Initialised AES-256 CBC client->server encryption
15:08:56 Initialised HMAC-SHA1 client->server MAC algorithm
15:08:56 Initialised AES-256 CBC server->client encryption
15:08:56 Initialised HMAC-SHA1 server->client MAC algorithm
15:08:58 Pageant is running. Requesting keys.
15:08:58 Pageant has 1 SSH-2 keys
15:08:58 Trying Pageant key #0
15:08:59 Server refused public key
15:08:59 Keyboard-interactive authentication refused

================================================== =

Thanks in advance for the resolutions.

Regards,
Anand