Find the answer to your Linux question:
Results 1 to 6 of 6
How to grant write priviligies to files/directories on additional disks? I have some additonal disks mounted on my SuSe. The disks come from Win98 partitions. All the files/directories are owned ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    50

    how to grant write priviligies to files/directories on addit


    How to grant write priviligies to files/directories on additional disks?

    I have some additonal disks mounted on my SuSe. The disks come from Win98 partitions. All the files/directories are owned by root, group root.
    chmod can not grant write priviligies to group and others.
    chown says that this operation is not permited

    Perhaps there is something in mounting this disks?
    In the fstab
    /dev/hdb1 /windows/D vfat defaults 0 0

    any hints?

  2. #2
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    try adding 'user' to the options field.. (w/o quotes) that will allow users to mount and umount the filesystem... IIRC, only the person that mounts a Windows partition can access it in any way...
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    You can use user or users. I also put in rw and exec to give rwx perms. across the FAT drive. You cannot use Linux chmod/chown commands with a FAT drive. FAT doesn't have the capacity for Linux chmod/chown commands. The owner:group will be whoever mounts it and that user's primary group. The permissions will be as specified in the mount statement (fstab options).
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. #4
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225
    which distro are you using...because the lines in fstab varies in fedora, mandrake and slack 10?

  5. #5
    Just Joined!
    Join Date
    Sep 2004
    Posts
    50
    I use suse 9.1

  6. #6
    Just Joined!
    Join Date
    Sep 2004
    Posts
    50
    the following works fine when typed in fstab
    /dev/hdb1 /windows/D vfat auto,users,exec,rw,umask=000

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •