Find the answer to your Linux question:
Results 1 to 3 of 3
Hello fooks, I already posted another thread but i thought this would be a good question also. Right now I got a problem with freeradius. The problem is that when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8

    Freeradius connection to openssl


    Hello fooks,

    I already posted another thread but i thought this would be a good question also. Right now I got a problem with freeradius. The problem is that when I start it with the minimum configuration for certificate authentication it gives an error. See below.
    This is the only intresting part of the radiusd -X output. When I google this it says: "You need to install the OpenSSL *development* headers." I also discovered a very important stap. It says that it can't comunicate with openssl because of the licenses ( Can u believe it and they say it is free and whatever... ). Right now there seems to be a fix for it in Ubuntu but like we all know it is different than RedHat. So to make my question short... Do you know another fix for this... So it can communicate with openssl

    This is my linux version: Redhat 5.4
    # uname -a
    Linux localhost.localdomain 2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:54 EDT 2009 i686 i686 i386 GNU/Linux

    This is my FreeRadius version:
    radiusd: FreeRADIUS Version 2.1.6, for host i686-pc-linux-gnu, built on Feb 8 2010 at 12:29:59

    I hope someone could give me the right download package because I just can't find it

    Thanks a lot anyway...


    Ignoring EAP-Type/tls because we do not have OpenSSL support.
    Ignoring EAP-Type/ttls because we do not have OpenSSL support.
    Ignoring EAP-Type/peap because we do not have OpenSSL support.
    Module: Linked to sub-module rlm_eap_mschapv2
    Module: Instantiating eap-mschapv2
    mschapv2 {
    with_ntdomain_hack = no
    }
    rlm_eap: No such sub-type for default EAP type ttls
    /usr/local/etc/raddb/eap.conf[1]: Instantiation failed for module "eap"
    /usr/local/etc/raddb/sites-enabled/inner-tunnel[223]: Failed to find module "eap".
    /usr/local/etc/raddb/sites-enabled/inner-tunnel[176]: Errors parsing authenticate section.
    Errors initializing modules
    Last edited by dre2007; 02-11-2010 at 09:33 AM. Reason: Found extra information

  2. #2
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8
    Okay I found the answer myself... And I will post it for you other guys and let this topic open for you guys. Just enter the following command in you raddb/certs/ directory

    dd if=/dev/urandom of=random count=2

    this is for the random file that you need to have( look at eap.conf for random)


    other command is the dh file

    openssl dhparam -check -text -5 512 -out dh

    this is for the dh file that you need to have ( look at eap.conf for "dh" above random.)

    Let me know if it helped you

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8
    hello all,
    I found the answer. You need to install a stable release version of it. Just google for stable snapshot and download the openssl and freeradius version of it or click the link here and Follow the guidlines. dslreports.com/forum/remark,9286052
    I hope I helped you guys. Soon I will post a manual.

    Regards André Boom

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •