Find the answer to your Linux question:
Results 1 to 3 of 3
I created a user "CATUSER" and using the usermod command I had set the secondary group of the "CATUSER" to "beagrp". usermod -a -G beagrp CATUSER ******************** $ whoami CATUSER ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    8

    Write Permisson Denied


    I created a user "CATUSER" and using the usermod command I had set the secondary group of the "CATUSER" to "beagrp".

    usermod -a -G beagrp CATUSER

    ********************
    $ whoami
    CATUSER

    $ id CATUSER
    uid=6002(CATUSER) gid=6002(CATUSER) groups=6002(CATUSER),515(beagrp) context=user_u:system_r:unconfined_t

    **********************


    Then i tried to create a file in the directory /apps for which the group is "beagrp" and the file permission settings for the directory is as follows:

    ***************
    $ cd /

    $ ls -lrt
    drwxrwxr-x 5 bea beagrp 4096 Jul 28 13:43 apps

    *************************

    But when i tried to create a file in the /apps directory as the user "CATUSER" i got a Permission denied error message.

    *************************
    $ touch a.txt
    touch: cannot touch `a.txt': Permission denied

    ********************************

    Am i missing here something. Can some one point out the mistake here and help me get out this issue?

    Thanks,
    Bala.

  2. #2
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    are you completely logging out or do you su to CATUSER?

    are you just doing:
    Code:
    su CATUSER
    try doing
    Code:
    su - CATUSER
    linux user # 503963

  3. #3
    Just Joined!
    Join Date
    Jul 2010
    Posts
    8
    Thanks for your reply. The issue is resolved now. After making the changes, I logged out completely and then logged in to create the file and it was successful.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •