Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I have a problem with my cryptsetup disk encryption. So I set up, installed it and everything. It works fine. The only thing is that I don't have read/write ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    6

    cryptsetup disk encryption problem


    Hi,

    I have a problem with my cryptsetup disk encryption.

    So I set up, installed it and everything. It works fine. The only thing is that I don't have read/write permission as a user. Everything is root and I can't get rid of it.

    How do I change it so that I have full read/write permission as a user (only myself of course). Copying and pasting files as well.


    Thanks.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    This sounds like a simple solution, but I have to ask - did you chown (as root of course) the directory where the encrypted device is mounted? something like:

    Code:
    chown -R <USERNAME>.<GROUPNAME> /mnt/mountpoint
    I just tried that on a LUKS encrypted device on my system and it works just fine, after unmounting and remounting.

  3. #3
    Just Joined!
    Join Date
    Jul 2011
    Posts
    6
    That worked very nicely, thanks.

    Do you also know a way to set, when you click on "Places" and than your disk to open/mount it, that it will mount exactly where I want? i.e. in that mount directory I made.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    There may be a nice GUI way to do it, depending on your distro (Fedora, Ubuntu, etc.) and/or Desktop environ (Gnome, KDE, etc.), but with an encrypted disk, it gets a little tricky. I'll bet it can be done, though.

    What distro/ver of Linux are you using?

  6. #5
    Just Joined!
    Join Date
    Jul 2011
    Posts
    6
    I'm using Fedora 15.

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Have you set up entries in /etc/fstab and /etc/crypttab yet? Try this guide to help you with that. When you set up /etc/fstab, make sure you specify 'user' as a mount option (man 5 fstab).

    Once you have that working, maybe the Locations thing will work for you.

  8. #7
    Just Joined!
    Join Date
    Jul 2011
    Posts
    6
    Yes I have looked at those guides many times before, but it was always used for booting. But if I can use it for this purpose than I will.

    I would need some help setting it up.

    For example:

    In /etc/crypttab, "encrypt UUID="3948u-894483s-string-id-etc" none". Wherein "encrypt" is the name of the device/mapper.

    Which would equal, "cryptsetup luksOpen /dev/sda 'encrypt'".

    And in /etc/fstab, "UUID=3948u-894483s-string-id-etc /mountpointfolder ext4 default 0 0". And this should ensure that the encryption device or mapper will be mounted in the exact folder or space I want correct?


    And I have another question. Using a key file with luks, it can replace a password correct? So to open it I can either use key or password. But using a key it will not ask me for a password? There is no password on the key itself right?
    So its not like pgp for example which require a key and than asks you confirmation with a password.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •