Find the answer to your Linux question:
Results 1 to 2 of 2
hi, I just installed a secure cert. on my server and can not get it to work...I´ve checked apache´s config file for lines like: SSLCertificateFile /usr/share/ssl/certs/...... SSLCertificateKeyFile /usr/share/ssl/private/.... SSLCACertificateFile /usr/share/ssl/certs/.... ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    15

    secure cert. issue


    hi,
    I just installed a secure cert. on my server and can not get it to work...I´ve checked apache´s config file for lines like:

    SSLCertificateFile /usr/share/ssl/certs/......
    SSLCertificateKeyFile /usr/share/ssl/private/....
    SSLCACertificateFile /usr/share/ssl/certs/....

    which are all there, I can also see:
    SSLEngine on

    I have reissued the cert. several times & reinstalled but all I get from any internet browser is "Unable to connect".

    geotrust has this cert. checker that says the same. Unable to connect...

    if I run:
    netstat -nlp
    I can see that 69.41.178.91 is not listening on port 443 which is what I need...

    my server´s os is linux cent.

    any help will be very much appreciated. thanks in advance
    Last edited by apascal; 03-10-2012 at 06:29 AM.

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Posts
    15

    secure cert. issue

    I generated the CSR through the cpanel option for the account in question, submitted it to my ssl provider and obtained the CRT which I installed on WHM. WHM said the installation was successful and that apache restarted normally.
    I´ve checked the paths to key and cert on httpd.conf and they seem to be ok, the cabundle also seems to be fine.

    needless to say that the account in question has a dedicated IP which I can not find when running the following command:

    netstat -anp --tcp

    so I should be able to find
    myIP:443
    which is not there...

    I tried starting from scratch, reissued & reinstalled the CRT but all I get from any internet browser is "Unable to connect".

    if I run:
    openssl s_client -connect localhost:443 -state -debug
    it will work fine, but if I run:

    openssl s_client -connect my account:443 -state -debug
    all I get is:

    gethostbyname failure
    connect:errno=0

    could somebody please point me in the right direction?
    thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •