Find the answer to your Linux question:
Results 1 to 3 of 3
Hi there, I am running CentOS and have created one user named "pyapps" under which we'd like to run and compile some daemons. Logging in as root, then doing a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    2

    Virtual Memory Limits (limits.conf)


    Hi there,

    I am running CentOS and have created one user named "pyapps" under which we'd like to run and compile some daemons.

    Logging in as root, then doing a

    # su pyapps
    # ulimit -a|grep -i 'virtual memory'
    virtual memory (kbytes, -v) 200000


    reveals the virtual memory limit for this user. What's interesting is that the /etc/security/limits.conf file has the following entry:

    Code:
    pyapps          hard    as	1000000
    We have also tried putting the AT symbol before this entry and the virtual memory limit remains the same. We have also rebooted the entire server after updating these entries. Still the same limit.

    Any ideas as to how to raise the virtual memory limit for this user? Any other things that might be keeping it limited? This is a cPanel webserver, btw.

    Thanks in advanced.

  2. #2
    Just Joined!
    Join Date
    Aug 2013
    Posts
    2
    SOLVED

    There is a configuration option in WHM called "fork bomb protection" that was enabled, causing the memory limit to be set low (forced). Now that I've disabled it, the memory limits are being set in accordance with limits.conf.

    Thanks.

  3. #3
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,532
    Thanks for posting the solution. For those of you wondering (as I was) wtf is whm?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •