Find the answer to your Linux question:
Results 1 to 7 of 7
I need to install some vulnerable web applications like Mutillidae,DVWA & other web apps to practice penetration testing.metasploitable 2 has these web app installed but can't update its old ubuntu ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    8

    Weak Linux Distro for practice ?


    I need to install some vulnerable web applications like Mutillidae,DVWA & other web apps to practice penetration testing.metasploitable 2 has these web app installed but can't update its old ubuntu server that does not support updates & lot of php error while updating. please suggest me ill configured weak linux distro to install these apps.how about xubuntu ?


    Regards Skorpinok

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by skorpinok View Post
    I need to install some vulnerable web applications like Mutillidae,DVWA & other web apps to practice penetration testing.metasploitable 2 has these web app installed but can't update its old ubuntu server that does not support updates & lot of php error while updating.
    you can update old Ubuntu releases. you just have to modify the apt-get sources files. they are in /etc/apt/sources.list and you need to change the domain name of the URLs to point to http://old-releases.ubuntu.com ...but why do you want to apply updates? If you want the services to be vulnerable, then i'd think you *don't* want to apply updates. or is it that those apps you have require other packages to be updated first?

    please suggest me ill configured weak linux distro to install these apps.
    contradiction in terms, mate! Linux==secure. If you want an insecure Linux distro, just install a vanilla distro and:

    1) don't apply updates
    2) disable the firewall
    3) disable SELinux/AppArmor
    4) don't use filesystem encryption
    5) leave the root account enabled
    6) run any/all network-enabled services to entice would-be hackers

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    http://www.concise-courses.com/secur...p-ten-distros/
    Try that link. I think you might find some interesting choices to make.

    Sent from my SPH-D710VMUB using Tapatalk
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2013
    Posts
    8
    Thanks. where to Download Vanilla ? checked distro watch didnt find it..

    Regards
    slorpinok

  6. #5
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,622
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by skorpinok View Post
    Thanks. where to Download Vanilla ? checked distro watch didnt find it..
    heh, what i meant was, install any mainstream distro you want (Ubuntu, Fedora, etc.) and then do as I listed.

    Quote Originally Posted by elija View Post
    the ironic thing is, that it is not maintained anymore - so watch out, might be a security risk!

    srsly, that looks ideal.

  8. #7
    Just Joined!
    Join Date
    Aug 2013
    Posts
    8
    atreyu, million thanks, installing Xubuntu on Virtualbox inside Kali Linux, as my Kali is installed directly to O.S dual booted along with windows 7. after that i will go for Mutilliade,DVWA & install using Xampp.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •