Find the answer to your Linux question:
Results 1 to 7 of 7
how can i disable "that",so user can't use virtual terminal!! thx.....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! kudos's Avatar
    Join Date
    Apr 2006
    Posts
    8

    Smile disable ctrl+Alt+Fx?


    how can i disable "that",so user can't use virtual terminal!!
    thx..

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    The actions taken by these keys should be laid out in /etc/inittab though you may need to keep one virtual terminal alive for the system, or possibly just change the key combination.

  3. #3
    Just Joined! kudos's Avatar
    Join Date
    Apr 2006
    Posts
    8

    key?

    Quote Originally Posted by bigtomrodney
    .......possibly just change the key combination.
    where i can change the key combination...???

  4. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    This file varies greatly from one ditribution to another - can you post the contents of your /etc/inittab here please?

  5. #5
    Just Joined! kudos's Avatar
    Join Date
    Apr 2006
    Posts
    8

    /etc/inittab

    Quote Originally Posted by bigtomrodney
    This file varies greatly from one ditribution to another - can you post the contents of your /etc/inittab here please?

    which line should i change...???
    Attached Files Attached Files

  6. #6
    Linux User
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    401
    No. inittab file control the virtual terminal, but that key combination is controlled by X server. Even if you disable virtual terminals, users can still switch to the virtual terminal (even if there is no login prompt).

    You can modify you're X server configiuration with the following section:

    Code:
    Section "ServerFlags"
    
    Option "DontVTSwitch"
    Option "DontZap"
    
    EndSection
    This disable also the Ctrl+Alt+Backspace combination.

    However, to have a stronger configuration, it's better to disable virtual terminals.
    When using Windows, have you ever told "Ehi... do your business?"
    Linux user #396597 (http://counter.li.org)

  7. #7
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Sorry for not getting back to you , I missed the post until it was bumped. Look at the entries below from /etc/inittab
    Code:
    # Run gettys in standard runlevels
    1:2345:respawn:/sbin/mingetty tty1
    #2:2345:respawn:/sbin/mingetty tty2
    #3:2345:respawn:/sbin/mingetty tty3
    #4:2345:respawn:/sbin/mingetty tty4
    #5:2345:respawn:/sbin/mingetty tty5
    #6:2345:respawn:/sbin/mingetty tty6
    The first digit is the virtual terminal number,the type of generation, the following digits are the runlevels in which the virtual terminal is created, followed by the command to launch the terminal.

    You can disable the virtual terminal by setting the 'respawn' section to 'off'' or by changing the runlevels in which it is present. For example, have them working in all runlevels but 5.
    Code:
    1:2345:off:/sbin/mingetty tty1
    I'm not sure of the effect of commenting the lines above, whether it stops them loading or just defaults to a standard setting. I do know however that if there are no virtual terminals that linux can act strange, so I would leave at least one active, if not for just emergency use.

    I'm looking at changing the key combination but I can't seem to find it. I will post back if I find it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •