Find the answer to your Linux question:
Results 1 to 9 of 9
Hi guys, My problem is that I just installed a Fedora 5 with apache 2.2.2 and it's supposed to listen on all ip address. I tested with "lynx localhost" and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4

    Port 80 Blocked.


    Hi guys,

    My problem is that I just installed a Fedora 5 with apache 2.2.2 and it's supposed to listen on all ip address. I tested with "lynx localhost" and it worked fine, what I'm missing? I can ping it but when i try to access from another machine it does not respond, it can be the linux firewall, and if this is the case, how can I fix it?

    Thank you and best regards,

    Daniel Hernandez.

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    Check and make sure that your server is acting in Secure mode, i.e. type https://youripaddress and see what happens. You mentioned successfully connecting from the machine itself by typing http://localhost, correct? Apache2.conf sets the listener and if I'm not mistaken, the default port is 80, not all of them. That wouldn't be very secure now would it?

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    in the httpd.conf is listening on the 80 por only, i tryied https://ipaddress from the other machine, and it did nothing.

  4. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    Disable SE-Linux in your firewall settings and perhaps, try disabling the firewall to see if you can connect. Report your results.

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    I disabled the iptables service and it worked, now I have to allow the port 80 on the iptables.

    Thank you very much.

  6. #6
    Linux Enthusiast
    Join Date
    Jul 2005
    Location
    Maryland
    Posts
    522
    Quote Originally Posted by breydan
    I disabled the iptables service and it worked, now I have to allow the port 80 on the iptables.
    Thank you very much.
    Type:
    Code:
    setup
    then go to firewall configuration and enable it there.
    Edit: I hope I remember it correctly (I don't have Fedora at the moment).

  7. #7
    Just Joined! Ossiriss's Avatar
    Join Date
    Jul 2006
    Location
    Romania/Pitesti
    Posts
    52
    I posted here not to open another thread...
    My problem is that i am taking internet from a windows computer thrue ICS.
    I can use the ftp, the http but my valknut and ktorrent does not connect.Why?I have added some ports the vlk and kt use as default to the win firewall but still no resut.What should i do?

  8. #8
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    internet from a windows computer thrue ICS
    I used to use ICS, and you need a program to set up port forwarding.
    I can't remember what I used.

    http://www.google.com/search?client=...=Google+Search

  9. #9
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    Thank you very much.

    Regards,

    Daniel Hernandez

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •