Find the answer to your Linux question:
Results 1 to 5 of 5
I have a weird issue and I can't seem to figure it out. I have 2 systems which I have been playing with both of them run the exact same ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3

    IPTable user-defined chains disappearing!


    I have a weird issue and I can't seem to figure it out.

    I have 2 systems which I have been playing with both of them run the exact same installations of centos one is an amd athlon 3000 and the other is a dual xeon 2.8 both with 1gb of ram nothing major.

    On my dual xeon system I created a user-defined chain and put some rules in that chain. After a few minutes the chain disappears.

    On my amd system, same thing yet the chain is still active.

    My thought is something is clearing the chains, what... I have no idea!

    Any assistance would be greatly appreciated.

  2. #2
    Just Joined! pcrack's Avatar
    Join Date
    May 2006
    Location
    Philippines
    Posts
    23

    chains

    Did you save it? service iptables save to verify iptables -L

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3
    pcrack,

    Indeed I tried that, same issue after a few minutes it just... disappears. All my rules for that specific target in INPUT and "chris" the user-defined chain go bye bye. I ran some rootkit checks on the system to ensure that the system was not possibly rooted everything came back clean on that area. I am at a loss here!

  4. #4
    Linux User cyberinstru's Avatar
    Join Date
    Jan 2007
    Location
    India
    Posts
    362
    Do u hve any other firewall applns like (firestarter, etc) installed? If so, that wud erase custom chains periodically.

    Check your crontab or at for any scheduled tasks?

    better you flush all your rules and see if you cud find any rules after sometime, to make it sure that some firewall appln is running..

    Gud luk

  5. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3
    cyberinstru,

    I did not check for any other firewalls except for APF considering this was an out of box install like the other system. With that said I am not seeing anything else writing rules out to the firewall, rules just disappear... I checked crontab and nothing is running in crontab for the root user, maybe I am not checking the right place? How would I go about seeing if another firewall is installed on the system, this part I am a bit new to.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •