Find the answer to your Linux question:
Results 1 to 6 of 6
I am having a problem getting a Fedora Redhat box to service DNS as a caching-DNS server. I have the named service up and running, however it is not responding ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Location
    Pittsburgh
    Posts
    2

    Caching DNS problem


    I am having a problem getting a Fedora Redhat box to service DNS as a caching-DNS server. I have the named service up and running, however it is not responding to queries from other machines. I disabled the firewall to ensure I am not blocking port 53.

    Any suggestions?

    Thanks

  2. #2
    Linux User infoshirish's Avatar
    Join Date
    May 2007
    Location
    Pune, India
    Posts
    397

    Cool

    Hey,
    What queries you are firing on other machines? What is the output of those queries?
    Can you post them both? Also post the output of
    #dig domainname
    #nslookup domainname
    Regards,

    who |grep -i blonde |
    date; cd~; unzip; touch;
    strip; finger; mount; gasp;
    yes; uptime; umount;
    sleep

    Newbie clicks
    http://www.linuxforums.org/forum/lin...ead-first.html

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    24
    You could check that BIND (I assume you're using BIND) is listening on all interfaces (perhaps it's just listening on loopback), and don't forget to check /var/log/messages

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2007
    Location
    Pittsburgh
    Posts
    2

    Figured it out

    Hey guys thanks for the help. After playing around a bit more, I got it to work. However it may not be the ideal configuration. I changed several options in named.conf from localhost to "any". That did the trick. I also tried to serve some local name resolution, however that didn't work, so I commented it out below.

    options {
    listen-on port 53 { 127.0.0.1; };
    listen-on port 53 { 10.161.205.100; };
    listen-on port 53 { 192.168.168.80; };
    listen-on-v6 port 53 { ::1; };
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/data/named_mem_stats.txt";
    // query-source port 53;
    // query-source-v6 port 53;
    allow-query { any; };
    recursion yes;
    version "0";
    };
    logging {
    channel default_debug {
    file "data/named.run";
    severity dynamic;
    };
    };
    view localhost_resolver {
    match-clients { any; };
    match-destinations { any; };
    recursion yes;
    include "/etc/named.rfc1912.zones";
    };

    // view "external" {
    // match-clients { !localhosts; any; };
    //recursion yes;
    //allow-transfer { dns_slaves; };
    //zone "example.com" {
    // type master;
    // file "example.com.zone";
    // };
    //};

    zone "." {
    type hint;
    file "/var/named/root.hints";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "/var/named/127.0.0";
    };

  6. #5
    Linux User infoshirish's Avatar
    Join Date
    May 2007
    Location
    Pune, India
    Posts
    397
    Hey,
    Your most welcome. That was cool stuff.
    Regards,

    who |grep -i blonde |
    date; cd~; unzip; touch;
    strip; finger; mount; gasp;
    yes; uptime; umount;
    sleep

    Newbie clicks
    http://www.linuxforums.org/forum/lin...ead-first.html

  7. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11
    Which OS you are installed.

    For Caching nameserver, you need start named service and then run command -

    Code:
    rndc dumpdb
    before rndc command first try with "nslookup domainname"

    it will create file called cache_dump.db in /var/named/chroot/var/named/data/


    This is for manualy for crontab you want to put entry like this

    Code:
    */10 * * * * root /usr/sbin/rndc dumpdb
    every 10 sec it will run in background

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •