Find the answer to your Linux question:
Results 1 to 5 of 5
hello guys, I've just setup (almost complete) a centos box and isntalled vsftpd I have created 2 users with 'useradd' and they're correctly shown in /etc/passwd I have added these ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Fed
    Fed is offline
    Just Joined!
    Join Date
    Apr 2006
    Location
    Italy
    Posts
    16

    Question vsftpd authentication not working


    hello guys, I've just setup (almost complete) a centos box and isntalled vsftpd
    I have created 2 users with 'useradd' and they're correctly shown in /etc/passwd
    I have added these users both to vsftpd.ftpusers and vsftpd.user_list

    this is my configuration file

    Code:
    # Example config file /etc/vsftpd/vsftpd.conf
    #
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    #
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    #
    # Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    anonymous_enable=NO
    #
    # Uncomment this to allow local users to log in.
    local_enable=YES
    #
    # Uncomment this to enable any form of FTP write command.
    write_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    local_umask=022
    #
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    #anon_upload_enable=YES
    #
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    #anon_mkdir_write_enable=YES
    #
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES
    #
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    #chown_uploads=YES
    #chown_username=whoever
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    xferlog_file=/var/log/vsftpd.log
    #
    # If you want, you can have your log file in standard ftpd xferlog format
    xferlog_std_format=YES
    #
    # You may change the default value for timing out an idle session.
    #idle_session_timeout=600
    #
    # You may change the default value for timing out a data connection.
    #data_connection_timeout=120
    #
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    #nopriv_user=nobody
    #
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    #async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that turning on ascii_download_enable enables malicious remote parties
    # to consume your I/O resources, by issuing the command "SIZE /big/file" in
    # ASCII mode.
    # These ASCII options are split into upload and download because you may wish
    # to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
    # without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
    # on the client anyway..
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    #
    # You may fully customise the login banner string:
    ftpd_banner=**** WARNING - Your actions are being logged ****
    
    #
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #deny_email_enable=YES
    # (default follows)
    #banned_email_file=/etc/vsftpd.banned_emails
    #
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    chroot_list_enable=YES
    # (default follows)
    chroot_list_file=/etc/vsftpd.chroot_list
    #
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    #ls_recurse_enable=YES
    
    pam_service_name=vsftpd
    userlist_enable=YES
    #enable for standalone mode
    listen=YES
    tcp_wrappers=YES
    userlist_deny=NO
    filezilla gives this
    Code:
    Status:	Connecting to 192.168.0.87:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220 **** WARNING - Your actions are being logged ****
    Command:	USER testsite
    Response:	331 Please specify the password.
    Command:	PASS *****
    Response:	530 Login incorrect.
    Error:	Could not connect to server
    and this the content of var/log/messages
    Code:
    Aug 10 18:36:18 server27 vsftpd[4295]: PAM-listfile: Refused user testsite for service vsftpd
    Aug 10 18:36:18 server27 vsftpd(pam_unix)[4295]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=192.168.0.3  user=testsite

  2. #2
    Linux User infoshirish's Avatar
    Join Date
    May 2007
    Location
    Pune, India
    Posts
    397

    Cool

    Hey,
    The server you are trying to connect is configured for ftp? You cannot connect before the remote server allowes you to connect via ftp. Moreover vsftpd service should also be running on that server. Are you able to ftp yourself machine with ip as well as loopback(127.0.0.1)
    Regards,

    who |grep -i blonde |
    date; cd~; unzip; touch;
    strip; finger; mount; gasp;
    yes; uptime; umount;
    sleep

    Newbie clicks
    http://www.linuxforums.org/forum/lin...ead-first.html

  3. #3
    Fed
    Fed is offline
    Just Joined!
    Join Date
    Apr 2006
    Location
    Italy
    Posts
    16
    Quote Originally Posted by infoshirish View Post
    Hey,
    The server you are trying to connect is configured for ftp? You cannot connect before the remote server allowes you to connect via ftp. Moreover vsftpd service should also be running on that server. Are you able to ftp yourself machine with ip as well as loopback(127.0.0.1)
    I don't have tried from the server itself, but I don't see how this would make any difference, the client and the server actually exchange messages (see the output I posted) hence vsftpd is running and the firewall allows me to reach port 21, it's just that my users are refused

  4. #4
    Just Joined!
    Join Date
    Apr 2004
    Location
    @EARTH
    Posts
    17
    The default vsftpd.conf file is ok.
    Just change lines that is, "anonymous_enable=NO" and local_enable= YES
    No need to add users in any of these vsftpd.ftpusers and vsftpd.user_list files.
    Restart vsftpd service and it should work.

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11
    you have create user in linux "testsite"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •