Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I am running jboss in a linux machine. I am able to open the home page of jboss in the sane machine where it is installed using the URL ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    26

    Application runnnig in a Linux machine - not able to access from windows.


    Hi,

    I am running jboss in a linux machine. I am able to open the home page of jboss in the sane machine where it is installed using the URL

    Code:
    http"//localhost:8080
    But the page is not coming up when i try the URL in the same machine where jboss is installed

    Code:
    http://<IP Address>:8080/

    Also, the page is not up when i try to access it from any windows machine.

    I am sure that Jboss is running on port 8080 without any error.

    Any help regarding this is highly appriciated.



    Thanks in advance,
    GOKUL
    Last edited by gokul_ifs; 08-17-2007 at 11:06 AM. Reason: To specify correct URL

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,805
    This could be any number of problems, things to try:

    - Firewalling isn't turned on is it? If your firewall is blocking external connections to port 8080, then you wont get a response at another machine.

    - I've seen port 8080 used for other services, such as squid proxy. There is nothing else running on that port is there?

    - Your network card is operating right, isn't it? If it's misconfigured the routes internally to localhost may work, but anyone trying to get a connection over the lan port may encounter problems.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    26
    Quote Originally Posted by Roxoff View Post
    This could be any number of problems, things to try:

    - Firewalling isn't turned on is it? If your firewall is blocking external connections to port 8080, then you wont get a response at another machine.

    - I've seen port 8080 used for other services, such as squid proxy. There is nothing else running on that port is there?

    - Your network card is operating right, isn't it? If it's misconfigured the routes internally to localhost may work, but anyone trying to get a connection over the lan port may encounter problems.
    Hi Roxoff,

    - I am sure port 8080 is not used by other services and network card is working fine.

    - The same Jboss when installed on Windows it works fine. so i think the firewall is not blocking external connections to 8080.

    Could you pls share more ideas with me regarding this.

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    26

    Application runnnig in a Linux machine - not able to access from windows

    Quote Originally Posted by Roxoff View Post
    This could be any number of problems, things to try:

    - Firewalling isn't turned on is it? If your firewall is blocking external connections to port 8080, then you wont get a response at another machine.

    - I've seen port 8080 used for other services, such as squid proxy. There is nothing else running on that port is there?

    - Your network card is operating right, isn't it? If it's misconfigured the routes internally to localhost may work, but anyone trying to get a connection over the lan port may encounter problems.
    Hi Roxoff,

    - I am sure port 8080 is not used by other services and network card is working fine.

    - The same Jboss when installed on Windows it works fine. so i think the firewall is not blocking external connections to 8080.

    Could you pls share more ideas with me regarding this.

  5. #5
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,805
    The firewall I'm talking about is the internal one on the Linux machine. If you boot it up in windows, the Linux firewall wont be running, so you wont see problems related to it.

    In Linux, launch your firewall control tool ('system-config-securitylevel' on CentOS or Fedora, but I'm not sure what system you've got) and open port 8080. You could even turn off the firewall and SELinux system temporarily while you test this, but dont forget to turn it back on again...
    Linux user #126863 - see http://linuxcounter.net/

  6. #6
    Just Joined!
    Join Date
    Jun 2007
    Posts
    46
    hi
    please paste ur configuration file here.

  7. #7
    Just Joined!
    Join Date
    Sep 2007
    Posts
    1
    Hi,

    I am also facing the same problem even after

    - Firewalling is turned off.
    - 8080 is not used for other services.

    Thanks in advance,

    Buddha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •