Find the answer to your Linux question:
Results 1 to 6 of 6
I've searched high an low and am just stuck. I have a Coolmax 550 NAS box on my wireless network. It acts as an SMB server. WinXP can see it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    Samba Client Won't Mount Shares on Reboot


    I've searched high an low and am just stuck. I have a Coolmax 550 NAS box on my wireless network. It acts as an SMB server. WinXP can see it with no problems. I have added lines to the /etc/fstab on my Mandriva 2007 Linux box to mount the shares at startup, but the shares are not re-mounted when I reboot Linux. Here's a portion of my /etc/fstab file that "should" mount one of these shares at startup:

    //baumann_nas/media /media/media smbfs credentials=/etc/samba/auth.baumann_nas.bruce,dmask=777,fmask=777,gid=nas ,uid=bruce,rw 0 0

    The Coolmax uses uC OS, but I don't think it's an issue with the Coolmax.

    Can anyone provide any insight on this? One thing I did read in the mount man page was the _netdev option to indicate that mounting should not occur until after the network is up. But I don't think that's where the problem lies, either. I would "think" that the system would recognize that smbfs shares would probably be network shares.

    Once I log in as root and do mount -a, all the shares are visible. I do have to do this as root, probably because I didn't specify the user option to allow users to mount the shares.

    If anyone has any thoughts on what I should try, I'd appreciate hearing them.

    Thanks.

  2. #2
    Just Joined!
    Join Date
    Jun 2007
    Posts
    46
    hi
    paste error massage that you are getting.

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3
    Here's my latest /var/log/prcsys.log file. The error message indicates that the network is unreachable, however the network is up, as indicated previously with the log messages

    Bringing up interface eth2: Error for wireless request "Set Mode" (8B06) :
    invalid argument "Roaming".
    [ OK ]
    Waiting for network to be up[ OK ]

    Also, it seems strange to me that the SMB and NMB services aren't even started until after all this.

    The /var/log/prcsys.log file follows:

    WARNING ! /etc/rc5.d//S50kav4ws doesn't provides anything, auto-adding his name
    Activating Compat-mode for non LSB-script lisa
    Activating Compat-mode for non LSB-script perforce
    Activating Compat-mode for non LSB-script rc.local
    Starting wltool: [ OK ]

    Starting atd: [ OK ]

    Setting CPU frequency settings: [ OK ]

    Starting acpi daemon: [ OK ]

    Starting system message bus: [ OK ]

    Starting system logger: [ OK ]

    Starting kernel logger: [ OK ]

    Starting crond: [ OK ]

    Enabling laptop mode: enabled, active [unchanged].
    Starting nscd: [ OK ]

    Checking if partitions have enough free diskspace: [ OK ]

    Cannot load kavmon kernel module
    kavmonitor not started: system error
    Starting HAL daemon: [ OK ]

    Starting hpiod: [ OK ]

    Starting hpssd:
    HP Linux Imaging and Printing System (ver. 1.6.9)
    Services and Status Daemon ver. 7.5

    Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.


    HP Linux Imaging and Printing System (ver. 1.6.9)
    Services and Status Daemon ver. 7.5

    Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.

    [ OK ]

    Checking for new hardwareCompiling...
    Initializing...
    Determining Zones...
    IPv4 Zones: net loc
    Firewall Zone: fw
    Validating interfaces file...
    Validating hosts file...
    Validating Policy file...
    Determining Hosts in Zones...
    net Zone: eth0:0.0.0.0/0
    loc Zone: eth2:0.0.0.0/0 eth1:0.0.0.0/0
    Pre-processing Actions...
    Pre-processing /usr/share/shorewall/action.Drop...
    Pre-processing /usr/share/shorewall/action.Reject...
    Pre-processing /usr/share/shorewall/action.Limit...
    Deleting user chains...
    Compiling /etc/shorewall/routestopped ...
    Compiling Accounting...
    Creating Interface Chains...
    Compiling Proxy ARP
    Compiling NAT...
    Compiling NETMAP...
    Compiling Common Rules
    Compiling IP Forwarding...
    Compiling IPSEC...
    Compiling /etc/shorewall/rules...
    Compiling /etc/shorewall/tunnels...
    Compiling Actions...
    Compiling /usr/share/shorewall/action.Drop for Chain Drop...
    Compiling /usr/share/shorewall/action.Reject for Chain Reject...
    Compiling /etc/shorewall/policy...
    Compiling Masquerading/SNAT
    Compiling /etc/shorewall/tos...
    Compiling /etc/shorewall/ecn...
    Compiling Traffic Control Rules...
    Validating /etc/shorewall/tcdevices...
    Validating /etc/shorewall/tcclasses...
    Compiling Rule Activation...
    Compiling Refresh of Black List...
    Compiling Refresh of /etc/shorewall/ecn...
    Validating /etc/shorewall/tcdevices...
    Validating /etc/shorewall/tcclasses...
    Shorewall configuration compiled to /var/lib/shorewall/.start
    Processing /etc/shorewall/params ...
    Starting Shorewall....
    Initializing...
    Processing /etc/shorewall/init ...
    Clearing Traffic Control/QOS
    Deleting user chains...
    Processing /etc/shorewall/continue ...
    Enabling Loopback and DNS Lookups
    Setting up Accounting...
    Creating Interface Chains...
    Setting up Proxy ARP...
    Setting up one-to-one NAT...
    Setting up SMURF control...
    Processing /etc/shorewall/initdone ...
    Setting up Black List...
    Setting up ARP filtering...
    Setting up Accept Source Routing...
    Setting up SYN Flood Protection...
    Setting up IPSEC management...
    Setting up Rules...
    Setting up Tunnels...
    Setting up Actions...
    Creating action chain Drop
    Creating action chain Reject
    Creating action chain dropBcast
    Creating action chain dropInvalid
    Creating action chain dropNotSyn
    Applying Policies...
    Setting up Masquerading/SNAT...
    Setting up TOS...
    Setting up ECN...
    Setting up TC Rules...
    Activating Rules...
    Processing /etc/shorewall/start ...
    Processing /etc/shorewall/started ...
    done.
    [ OK ]

    Bringing up loopback interface: [ OK ]

    Bringing up interface eth2: Error for wireless request "Set Mode" (8B06) :
    invalid argument "Roaming".
    [ OK ]

    Waiting for network to be up[ OK ]

    Starting portmapper: [ OK ]

    Starting mandi daemon: mandi_daemon_add_watch(): READABLE
    unable to open white list file
    [ OK ]

    Syncing time for ntpd: Error : Temporary failure in name resolution
    Error : Temporary failure in name resolution
    Error : Temporary failure in name resolution
    Looking for host 0.us.pool.ntp.org and service ntp
    Looking for host 1.us.pool.ntp.org and service ntp
    Looking for host 2.us.pool.ntp.org and service ntp
    [FAILED]

    Starting ntpd: [ OK ]

    Starting xinetd: [ OK ]

    Starting Avahi daemon: [ OK ]

    Starting X Font Server: [ OK ]

    Starting display manager: [ OK ]

    Mounting SMB filesystems: Error connecting to 192.168.1.4 (Network is unreachable)
    5182: Connection to baumann_nas failed
    SMB connection failed
    Error connecting to 192.168.1.4 (Network is unreachable)
    5359: Connection to baumann_nas failed
    SMB connection failed
    Error connecting to 192.168.1.4 (Network is unreachable)
    5360: Connection to baumann_nas failed
    SMB connection failed
    Error connecting to 192.168.1.4 (Network is unreachable)
    5361: Connection to baumann_nas failed
    SMB connection failed
    Error connecting to 192.168.1.4 (Network is unreachable)
    5363: Connection to baumann_nas failed
    SMB connection failed
    Error connecting to 192.168.1.4 (Network is unreachable)
    5364: Connection to baumann_nas failed
    SMB connection failed
    [FAILED]

    Checking network-attached filesystems
    [ OK ]

    Mounting other filesystems: [ OK ]

    Loading keymap: us.uni Loading /usr/lib/kbd/keymaps/i386/qwerty/us.uni.kmap.gz
    [ OK ]

    Loading compose keys: compose.latin.inc Loading /usr/lib/kbd/keymaps/include/compose.latin.inc.gz
    [ OK ]

    The BackSpace key sends: ^?[ OK ]

    Starting Clam AntiVirus Daemon: [ OK ]

    Starting YP server services: [ OK ]

    Starting YP map server: [ OK ]

    Starting Clam AntiVirus Update Daemon: [ OK ]

    Starting YP passwd service: [ OK ]

    Starting atieventsd: [ OK ]

    Starting SMB services: [ OK ]

    Starting NMB services: [ OK ]

    Starting NFS statd: [ OK ]

    Starting ALSA version 1.0.12: hda.[ OK ]

    Starting autofs: [FAILED]

    Adding loopback device to routing table ...
    Starting CUPS printing system: [ OK ]

    Starting postfix: [ OK ]

    Starting jexec servicesTotal time: 36 seconds

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User infoshirish's Avatar
    Join Date
    May 2007
    Location
    Pune, India
    Posts
    397
    Quote Originally Posted by bruceski View Post
    I've searched high an low and am just stuck. I have a Coolmax 550 NAS box on my wireless network. It acts as an SMB server. WinXP can see it with no problems. I have added lines to the /etc/fstab on my Mandriva 2007 Linux box to mount the shares at startup, but the shares are not re-mounted when I reboot Linux. Here's a portion of my /etc/fstab file that "should" mount one of these shares at startup:

    //baumann_nas/media /media/media smbfs credentials=/etc/samba/auth.baumann_nas.bruce,dmask=777,fmask=777,gid=nas ,uid=bruce,rw 0 0

    The Coolmax uses uC OS, but I don't think it's an issue with the Coolmax.

    Can anyone provide any insight on this? One thing I did read in the mount man page was the _netdev option to indicate that mounting should not occur until after the network is up. But I don't think that's where the problem lies, either. I would "think" that the system would recognize that smbfs shares would probably be network shares.

    Once I log in as root and do mount -a, all the shares are visible. I do have to do this as root, probably because I didn't specify the user option to allow users to mount the shares.

    If anyone has any thoughts on what I should try, I'd appreciate hearing them.

    Thanks.

    Hey,
    I guess your entry in fstab file is incorrect. Just try first with mount command.
    mount -t smbfs //winbox/share /mnt/mount_directory -o rw,username=<user name>,password=<password> Does smb share gets mounted? If yes just add this simple line in /etc/fstab.

    //winbox/share /mnt/mount_directory smbfs username=<user name>,password=<password> ,uid=<uid>,gid=<gid> 0 0

    Also in above line uid should be the userid number and gid should be your groupid number as specified for that user under /etc/passswd.
    Regards,

    who |grep -i blonde |
    date; cd~; unzip; touch;
    strip; finger; mount; gasp;
    yes; uptime; umount;
    sleep

    Newbie clicks
    http://www.linuxforums.org/forum/lin...ead-first.html

  6. #5
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3
    Thanks for the suggestion. I tried mount -t smbfs //baumann-nas/media /media/media -o rw,user=xxx,password=yyy

    where xxx and yyy are the appropriate user name and password. The shares were mounted successfully. So I added the corresponding line to /etc/fstab:

    //baumann-nas/media /media/media smbfs rw,user=xxx,password=yyy,uid=aaa,gid=bbb 0 0

    where aaa and bbb are the uid number and gid number. However, I still get the same error message at reboot indicating that the network is not reachable. I tried this without specifying the uid and gid, and also with specifying only uid and only gid. No combinations seemed to work.

    I do not know at what runlevel the mount -a is attempted during startup. Is it possible that it's attempted too early? I don't think so, but I'm not a power user, so it's just a guess.

  7. #6
    Just Joined!
    Join Date
    Oct 2009
    Posts
    2

    Possible reason

    What version of Linux are you using and what kernel?

    I just upgraded to Ubuntu Server 9.04 and found that my USB drive was not mounting in Fsck. The reason is that in the new version, the USB drive enumerating prior to fsck mounts were being setup.

    I added a script that paused for about 10 seconds prior to the system mounting the drives and all was good.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •