Hello everyone. I've got a network that has worked for quite some time with the following servers:

mail.domain.com
www.domain.com
data.domain.com

My mail server is running Windows AS 2000 with Exchange. Both the www and data servers are running Linux. All three have dedicated IP addresses and connection to my ISP. I have the data server sending out email but it shows up at the far end as "user@data.domain.com". I would like for it to show up at "user@domain.com". When I try things like setting "masquerade_domains = domain.com" in the main.cf file on the data server, some destinations out there reject the connection to deliver mail while some don't. Is there anyway to make this happen?

Thanks