Find the answer to your Linux question:
Results 1 to 3 of 3
Hi All, I am new to Linux and Postfix and have recently had to rebuild our company's mail server. We run CentOS 4.5 and Postfix and I have managed to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    3

    Configure Postfix and email addresses


    Hi All,
    I am new to Linux and Postfix and have recently had to rebuild our company's mail server. We run CentOS 4.5 and Postfix and I have managed to reconfigure the server os, dns * postfix etc and get the old accounts working fine but any new accounts i create add localhost to the email address before the domain name. E.g user@localhost.domain.com where it should be user@domain.com

    I have checked the settings in the main.cf file and everything seems to be OK from what I can see. Any ideas on how to remove this localhost from the new accounts?

    Any help would be great.

    Thanks

  2. #2
    Linux User infoshirish's Avatar
    Join Date
    May 2007
    Location
    Pune, India
    Posts
    397
    Quote Originally Posted by Azwar View Post
    Hi All,
    I am new to Linux and Postfix and have recently had to rebuild our company's mail server. We run CentOS 4.5 and Postfix and I have managed to reconfigure the server os, dns * postfix etc and get the old accounts working fine but any new accounts i create add localhost to the email address before the domain name. E.g user@localhost.domain.com where it should be user@domain.com

    I have checked the settings in the main.cf file and everything seems to be OK from what I can see. Any ideas on how to remove this localhost from the new accounts?

    Any help would be great.

    Thanks

    Hey,
    By default postfix uses local machine name. You need to change to your domain name. Go to your /etc/postfix/main.cf
    Replace parameter $myhostname to $mydomain (Your domain name) in the entire file.
    For i.e
    Code:
    myorigin = $mydomain
    Restart the service should work.
    Regards,

    who |grep -i blonde |
    date; cd~; unzip; touch;
    strip; finger; mount; gasp;
    yes; uptime; umount;
    sleep

    Newbie clicks
    http://www.linuxforums.org/forum/lin...ead-first.html

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    3
    HI infoshirish
    Thanks for the info. I have checked that setting in the mai.cf file and it is already set to $mydomain. Strange

    Here are the main settings for that file

    myhostname = BSYDMX01.bytecan.com.au
    mydomain = bytecan.com.au
    myorigin = $mydomain
    inet_interfaces = 192.168.8.1
    mydestination = $myhostname, localhost.$mydomain $mydomain

    Can you see anything that would be causing this? As far as I can see it is setup correctly?

    Thanks again

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •