Find the answer to your Linux question:
Results 1 to 8 of 8
hello guys ive just setted up ubuntu LAMP server package and i was really impressed, everything worked perfectly. I then install webmin and setted up postfix and dovecot (for IMAP ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8

    Exclamation Post Fix sends email but cannot receive...Big problem..helo


    hello guys ive just setted up ubuntu LAMP server package and i was really impressed, everything worked perfectly. I then install webmin and setted up postfix and dovecot (for IMAP and POP3)......

    But am now having a problem...no emails are coming through, they all bounce back (even when i tested sending to root@XXX.XXX.XXX.XXX (thats my ip) .... it didnt come, but i was able to send mails through webmin and i received it without any problem i am also able to send mail to user@mydomail.com (from webmin) and it went through.....so i am unsure of where the problem lies.....am also not able to access the mails using outlook...eventhough dovecot is working well.........The website opens perfectly.

    I dont know what step ive missed.......heres my postfix config file:

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname


    myhostname = $mydomain

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
    smtpd_sasl_security_options = noanonymous

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    mydestination = $myhostname, localhost.$mydomain, $mydomain
    mynetworks = 127.0.0.0/8, 192.168.1.0/24
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_protocols = all
    myorigin = /etc/mailname
    broken_sasl_auth_clients = yes
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    inet_interfaces = all

    Umm....any help will be very welcomed......also also...

    telnet localhost 25 from terminal give this:

    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mydomain.com ESMTP Postfix (Ubuntu)

    NOTE: ive changed instances of my domain name to mydomain.....so all mydomains are valid TLD domain names..

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    have you checked your mail logs, /var/log/mail.info mail.error mail.warn

    also have you tried to send an email thru telnet
    How to Send Email Using Telnet - wikiHow

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8
    Hi when i tried sending mail from telnet it block it....saying...


    Escape character is '^]'.
    220 mydomain.com ESMTP Postfix (Ubuntu)
    HELO mydomain.com
    250 mydomain.com
    MAIL FROM: rich@Mydomain.com
    250 Ok
    RCPT TO:somemail@yahoo.com
    554 <somemail@yahoo.com>: Relay access denied

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    you said its sending fine, so you need to check the reverse of what you tried, unless your machine is going to be the final destination for yahoo.com

    reverse the emails and report back results

  6. #5
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8
    ok will try right away....brb

  7. #6
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8
    HEllo i did that and it worked...it ended with:

    PHP Code:
    354 End data with <CR><LF>.<CR><LF>
    some test message here <CR><LF>.<CR><LF>
    .
    250 Okqueued as 977901EE4045
    quit 
    and i was able to get the email through webmin and also through squirell mail which is setted up.......


    ummm.....dunno wat the problem is...

  8. #7
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8
    so if i send from anywhere (yahoo.com or hotmail.com) it still dosent come...... could firewall have anything to do with this?....
    Last edited by samuelodofin; 09-17-2007 at 09:20 PM. Reason: typo

  9. #8
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8
    Hi thanks, i figured out the problem...my ports 143 and 953 were blocked

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •