Find the answer to your Linux question:
Results 1 to 3 of 3
Hey guys: I have centOS installed on one of the machines and all i am trying to is to use samba to access the /data (on which /dev/md0 is mounted). ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    10

    Unhappy Cant share mount point


    Hey guys:

    I have centOS installed on one of the machines and all i am trying to is to use samba to access the /data (on which /dev/md0 is mounted). I have tried a lot but couldnt share the mount point. I can share any folder if its not a mount point but as soon as i mount the disk on the dir windows gives me permission denied. I have tried changing all kinds of permission on the folder but couldnt do it. Here is me samba config

    [global]
    workgroup = MSHOME
    guest account = nobody
    security = user
    browseable = yes
    guest ok = no
    guest only = no
    log level = 3
    max log size = 100
    encrypt passwords = yes
    dns proxy = no


    [data]
    comment = Sysadmin Disks
    path = /data
    valid users = sysadmin
    force user = sysadmin
    force group = adm
    read only = no
    #guest ok = yes

    The testparm comes out OK. Per mission on dir is " drwxrwxrwx 4 sysadmin adm 4096 Sep 25 11:46 data "

    Pleassssssseeeee HELP

  2. #2
    Just Joined!
    Join Date
    Sep 2007
    Posts
    10
    Ok no one is answering! Do you think it could be because I am mounting a partition ? Do I need dfstab or sharetab. I know its NFS related but I was just wondering if that could be the problem.

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    10
    not an expert on this but i would think it's a permissions thing. if samba is not running as root then the user option would need to be added to /etc/fstab. or what i usually do is under a subdirectory of the mount point is where i put my samba shares. changing permissions won't help cause when it gets mounted the system takes over permissions to the mount point as defined by the fstab entry.
    /dev/hda1 /mnt/datadir ext3 defaults,users 0 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •