Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I've been trying to set up Samba on my home Linux machine running SuSE 10.1, so that I can access it from my WinXP machine. I want to use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    9

    Setiing up SMB, cannot browse shares on local machine


    Hello,

    I've been trying to set up Samba on my home Linux machine running SuSE 10.1, so that I can access it from my WinXP machine. I want to use the Linux machine to backup files from the family WinXP machine.

    To set it up, I followed the video guide here:
    SuSE Samba HowTo

    The steps I followed were:
    • From YaST, select "Network Service" -> Inetd, and set the toggle status of Swat to "on"
    • From YaST, select System -> "Runlevel Editor", and enable the services nmb, smb and smbfs
    • From a Konquerer window, start the "Samba Web Administration Tool" at localhost:901, configure the "Globals" and "Shares" tabs, and commit the changes. From the "Status" tab, restart the services nmbd and smbd.

    I noticed during the setup that some things didn't work as expected:
    • I couldn't start smbfs, it indicates "returned 6 (program is not configured)" from the Runlevel Editor, however I read on another posting that this isn't so important. Do I need this?
    • From the Samba Web Administartor Tool, on the Status tab, when I restart all the services, the page indicates that the services nmbd and smbd are stopped. However, checking the list of running processes in an xterm indicates that the services are running. Why execute this step from this tool if it can also be done from the Runlevel Editor, or are they the same?

    Anyway, I did a few tests:
    • When I open a Konquerer browser, and select "Network Folders" -> "SMB Shares" -> "Workgroup", I can see the machines attached to my workgroup LAN. However, when I select the local Linux machine, the system responds with "Timeout on server Linux PC".
    • When I select the WinXP machine on the Konquerer browser, the system prompts me with a authorisation pop-up window. When I fill in the username/password details, the responds with the same pop-up window, with the password field cleared. Does this mean that the access was refused? If so, why, since I specified a valid account on the WinXP machine (with the same user name as on the Linux machine)?
    • When I browse the workgroup LAN from the WinXP machine, I can see the Linux machine. However, when I double click it, after a long delay, it responds with "LinuxMachine is not accessible. You might not have permissions to to use this network resource"


    Can anyone help?

    Many thanks,
    Paul

    My smb.conf file is as as follows. The sections for my music backups and for WinXP machine backups appear at the end

    [global]
    workgroup = HOME
    interfaces = eth0
    bind interfaces only = Yes
    security = SHARE
    hosts equiv = /etc/hosts
    smb passwd file = /usr/bin/smbpasswd
    log file = /var/log/samba/%m.log
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    hostname lookups = Yes
    printcap name = cups
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain master = No
    wins support = Yes
    guest ok = Yes
    hosts allow = 192.168.0.0/255.255.255.0

    [homes]
    comment = Home Directories
    valid users = %S, %D%w%S
    read only = No
    inherit acls = Yes
    browseable = No

    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    create mask = 0600
    directory mask = 0700
    store dos attributes = Yes

    [home]
    comment = All users
    path = /home/
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/

    [home_groups]
    comment = All groups
    path = /home/groups/
    read only = No
    inherit acls = Yes
    case sensitive = No
    msdfs proxy = no

    [printers]
    comment = All Printers
    path = /var/tmp
    create mask = 0600
    printable = Yes
    browseable = No

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin, root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    [music]
    comment = Music archive
    path = /home/music
    read only = No

    [hp5160]
    comment = HP5160 backup files
    path = /home/backup/HP5160
    read only = No

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    9
    Just to add that I managed to solve the problem, using the following article:
    Linux.com :: Feature

    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •