Find the answer to your Linux question:
Results 1 to 2 of 2
hello managed to get a share up and running. my setup is for a small office. 2 groups, office (administrators) and floor (engineers) have setup users, they can now see ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Location
    Utah USA
    Posts
    8

    help to finish off samba config


    hello
    managed to get a share up and running.
    my setup is for a small office.
    2 groups, office (administrators) and floor (engineers)

    have setup users, they can now see and edit their own folders.
    for some reason, there are two named folders visible on the fileserver when users login. these two are effectively the same folder-when you click on them they both go to into the users 'home' and are editable. one shows as (home) and the other as (firstname.lastname) which is the individuals username.

    so.. firstly, can i just remove the [home] config? .. dont understand why they are getting two references to the same folder.

    secondly, i have created a share, [allusers] based on the howtoforge tutorial
    http://www.howtoforge.com/debian_etc...tdbsam_backend
    but the allusers folder, showing up on screen, will not allow access to users.

    heres my smb.conf .. can anyone shed light on why users can see but cant access the share?

    thank you...

    [global]
    workgroup = WORKGROUP
    server string = %h server
    obey pam restrictions = Yes
    passdb backend = tdbsam
    password program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
    syslog = 0
    log file = /var/log/samba/log.%m
    max log size = 1000
    dns proxy = No
    panic action = /usr/share/samba/panic-action %d
    invalid users = root


    [homes]
    comment = Home Directories
    valid users = %S
    create mask = 0660
    directory mask = 0771
    writeable = yes



    [printers]
    comment = All Printers
    valid users = %S
    create mask = 0660
    directory mask = 0771
    writeable = yes

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers

    [samba]
    valid users = @office, @floor
    read list = @office, @floor
    write list = @office, @floor
    read only = no


    [allusers]
    comment = All Users
    path = /home/shares/allusers
    valid users = @office, @floor
    force group = @office, @floor
    create mask = =0660
    directory mask = 0771
    writeable = yes

  2. #2
    Just Joined! megerdin's Avatar
    Join Date
    Jul 2007
    Location
    Sylhet,Bangladesh
    Posts
    78
    01. add correct path option in PRINTER section,
    add the line in ur Home section
    browseable = No
    02. make one group for alluser I guess it only office
    03. Then run the command
    chgrp office /home -R
    /etc/init.d/smb restart
    I think all r done

    let me know what r u doing..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •