I have compiled postfix with cyrus-sasl enable and I have followed the Postfix SASL Howto as it is to my centos. But my outgoing mail is not authenticated. Either I enable or disable the “my server requires authentication” option in outlook express my mail leave from the out look express, goes to the Postfix server and send to the correct mail box.

If I enable the option mail log displays

Oct 26 16:27:09 lasantha postfix/smtpd[3913]: connect from unknown[10.64.78.2]
Oct 26 16:27:10 lasantha postfix/smtpd[3913]: 00805212F0: client=unknown[10.64.78.2], sasl_method=LOGIN, sasl_username=user2
Oct 26 16:27:10 lasantha postfix/cleanup[3897]: 00805212F0: message-id=<20071026105710.00805212F0@mail.laknet.lk>
Oct 26 16:27:10 lasantha postfix/qmgr[3853]: 00805212F0: from=<user2@laknet.lk>, size=585, nrcpt=1 (queue active)
Oct 26 16:27:10 lasantha postfix/local[3899]: 00805212F0: to=<user1@laknet.lk>, relay=local, delay=0.12, delays=0.1/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
Oct 26 16:27:10 lasantha postfix/qmgr[3853]: 00805212F0: removed
Oct 26 16:27:10 lasantha postfix/smtpd[3913]: disconnect from unknown[10.64.78.2]

If I disable that mail log shows

Oct 26 16:48:53 lasantha postfix/smtpd[6556]: connect from unknown[10.64.78.2]
Oct 26 16:48:53 lasantha postfix/smtpd[6556]: 90FE5212F0: client=unknown[10.64.78.2]
Oct 26 16:48:53 lasantha postfix/cleanup[6559]: 90FE5212F0: message-id=<000801c817f5$e8d2e1e0$cb6b2b7c@abc>
Oct 26 16:48:53 lasantha postfix/smtpd[6556]: disconnect from unknown[10.64.78.2]
Oct 26 16:48:53 lasantha postfix/qmgr[3853]: 90FE5212F0: from=<user1@laknet.lk>, size=1310, nrcpt=1 (queue active)
Oct 26 16:48:53 lasantha postfix/local[6560]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Oct 26 16:48:53 lasantha postfix/local[6560]: 90FE5212F0: to=<user2@laknet.lk>, relay=local, delay=0.19, delays=0.15/0.03/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
Oct 26 16:48:53 lasantha postfix/qmgr[3853]: 90FE5212F0: removed

I need each and every instance to authenticate a mail comes from email client to smtp server (in short and sweet, I only need to set up a postfix server to accept mail from out look client to the server if the “my server requires authenticating enabled”)

How can I do this? What are the settings? I would appreciate if some one can help me?

Thanks