Find the answer to your Linux question:
Results 1 to 3 of 3
Hi folks, Ubuntu 7.04 server amd64 Just finished installing the mail server and encountered problem on testing it. Steps performed as follows; $ sudo useradd -m -s /bin/bash fmaster $ ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778

    Postfix - send mail problem


    Hi folks,


    Ubuntu 7.04 server amd64


    Just finished installing the mail server and encountered problem on testing it. Steps performed as follows;

    $ sudo useradd -m -s /bin/bash fmaster
    $ sudo passwd fmaster
    Code:
    Enter new UNIX password: 
    Retype new UNIX password: 
    passwd: password updated successfully
    $ telnet localhost 25
    Code:
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 ubuntu.xyz.com ESMTP Postfix (Ubuntu)
    ehlo localhost
    250-ubuntu.xyz.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    mail from: root@localhost
    250 2.1.0 Ok
    rcpt to: fmaster@localhost
    451 4.3.5 Server configuration error
    Please advise how to fix the problem. TIA


    satimis

  2. #2
    Linux User infoshirish's Avatar
    Join Date
    May 2007
    Location
    Pune, India
    Posts
    397
    Quote Originally Posted by satimis View Post
    Hi folks,


    Ubuntu 7.04 server amd64


    Just finished installing the mail server and encountered problem on testing it. Steps performed as follows;

    $ sudo useradd -m -s /bin/bash fmaster
    $ sudo passwd fmaster
    Code:
    Enter new UNIX password: 
    Retype new UNIX password: 
    passwd: password updated successfully
    $ telnet localhost 25
    Code:
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 ubuntu.xyz.com ESMTP Postfix (Ubuntu)
    ehlo localhost
    250-ubuntu.xyz.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    mail from: root@localhost
    250 2.1.0 Ok
    rcpt to: fmaster@localhost
    451 4.3.5 Server configuration error
    Please advise how to fix the problem. TIA


    satimis

    Hello,

    Have you configured your hostname? If yes what are the errors shown in
    /var/log/maillog and /var/log/messages?
    Or seems to have some configuration missing. Paste the configuration file.
    Regards,

    who |grep -i blonde |
    date; cd~; unzip; touch;
    strip; finger; mount; gasp;
    yes; uptime; umount;
    sleep

    Newbie clicks
    http://www.linuxforums.org/forum/lin...ead-first.html

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Quote Originally Posted by infoshirish View Post
    Hello,

    Have you configured your hostname? If yes what are the errors shown in
    /var/log/maillog and /var/log/messages?
    Or seems to have some configuration missing. Paste the configuration file.
    Hi infoshirish,

    I solved the problem sending mails to users on the same PC but now unable to send mails from Internet to this PC.

    Here is /etc/postfix/main.cf
    Code:
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = ubuntu.satimis.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = ubuntu.satimis.com, satimis.com, localhost.satimis.com, localhost.localdomain, localhost
    relayhost = 
    mynetworks = 127.0.0.0/8, 192.168.1.0/24
    mailbox_command = 
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    virtual_alias_maps = hash:/etc/postfix/virtual
    # Specify your NAT/proxy EXTERNAL address here.
    proxy_interfaces = 1.2.3.4
    $ hostname
    ubuntu

    $ hostname -f
    ubuntu.satimis.com


    I'm not sure whether it is the problem of this server OR mis-setting the DNS Control Panel on the Registrar's site. The domain is for testing use NOT for daily use. Previous it worked w/o problem.


    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •