Find the answer to your Linux question:
Results 1 to 4 of 4
I have installed BIND 9.4.1 on a machine running CENTOS 5. BIND starts fine if I run named, however it does not run in the startup at all. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Tennessee
    Posts
    40

    BIND not starting on startup CENTOS


    I have installed BIND 9.4.1 on a machine running CENTOS 5.

    BIND starts fine if I run named, however it does not run in the startup at all.

    I have rc.bind in the /etc/rc.d folder

    If I execute rc.bind start or restart from this point it works

    named is also in the /etc/rc.d/init.d folder if i execute ./named from this point it starts

    It is also in all the runlevel rc.d folders and starts fine if i run the symlinks there.

    Any ideas?

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,846
    Do 'chkconfig bind on', or use your service tool to enable it as a service.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Tennessee
    Posts
    40
    Thank you,

    Through KDE I enabled it as a service to start up, however that did not work.

    chkconfig bind on - returned command not found, on both this CENTOS and a Slackware machine.

    (DNS starts fine on the Slackware box)


    UPDATE!
    I added the startup to rc.local and it worked!

  4. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,846
    Quote Originally Posted by vern View Post
    UPDATE!
    I added the startup to rc.local and it worked!
    Yes, this works, but it's not the right way to do it. The problem here is that you're starting your DNS server after all the other Sys V init stuff has completed, so any services that rely on it will fail too. It might not affect you now, but when you start adding new stuff it might. You're better off doing this properly, and finding out why it didn't work in the first place is far more valuable than using a hack to fix it.

    You may well not have 'system-config-services' or 'chkconfig' installed. I cant remember which packages these come in, but you can find out easy enough with 'yum whatprovides <appname>'. Try 'yum whatprovides chkconfig', then install the package that it reports it to be in. Then you can run it in the way I suggested in my earlier post.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •