Find the answer to your Linux question:
Results 1 to 8 of 8
hi, all: I am a new one here. I searched in the old threads and tried every method but none seems to work. Here is my information: I have two ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3

    Samba setup problem


    hi, all:
    I am a new one here. I searched in the old threads and tried every method but none seems to work. Here is my information:
    I have two computers: one is windows xp and one is mandrake 10.
    I tried to install the Samba server on the mandrake machine and I used SWAT to configure the smb.conf file, here is the content:
    ******
    # Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2004/07/13 21:02:02

    # Global parameters
    [global]
    workgroup = ENGINEERING
    netbios name = WORKHORSE
    guest account = nbc
    password level = 20

    [homes]
    comment = Home Directories
    read only = No
    create mask = 0750
    browseable = No

    [tmp]
    comment = temporary directory
    path = /nbc/tmp
    valid users = nbc
    create mask = 0765

    [printers]
    comment = All Printers
    path = /usr/spool/samba
    printable = Yes
    browseable = No

    [BrotherHL1440]
    comment = BrotherHL1440
    path = /usr/spool/samba
    read only = No
    guest ok = Yes
    printable = Yes
    printer name = BrotherHL1440
    oplocks = No
    share modes = No

    ******

    The workgroup name is the same as windows' setting. I have user name 'nbc' in both machines with the same password.
    Here is the problem:
    At first, after I changed the smb.conf file and restart the samba server (using
    /etc/rc.d/init.d/smb restart), I cannot see the Samba server from windows' neighborhood,
    nor can I see the windows machine from Samba machine. However, I can ping each other using their IP address but not names. I then frustrated for some time, but for no reason, I can suddenly see the windows machine in Samba server, but when I tried to access it, it denied the action. (I use Smb4k to browse the network) I also cannot share the printer on Samba server.

    Thanks very much for any input.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Have you tried the smbmount command? You may be able to mount the remote share with that.

    Check around the options in Smb4k for the settings on which user it uses to browse...that may be causing problems, too.

    As for you're sharing, everything looks OK, so I'm not sure what's going on there.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    May 2004
    Location
    Staffordshire
    Posts
    6

    Samba Setup Problem

    Hello,

    Linux Newby so please ignore if I am talking rubbish........

    I have had a similar problem, however, I found out that, because I had the Linux Firewall Active, I had to open three ports up 137, 138, 139 (all on TCP) so that external requests could get on to the defined SAMBA shares.

    I use Fedora Core 2, so I used a program called "lokkit" to add the port exceptions. Yoiu can also do it from "System Settings""Security Level". Not sure if you have this on Mandrake.


  4. #4
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Try to setup samba with share mode first , it will then pass through all request to the samba server, if it has ipadress 192.168.0.101 just try to mount it from your XP with

    start->run->\\192.168.0.101

    Then you can change to usermode and define a user. You can view on a little howto i have on http://www.utterberg.com on samba for different settings and modes.

    To moun a xp-share from your linux just execute

    Code:
    mount -t smbfs //192.168.0.102/myxpshare /mnt/xpshare
    Make sure that you have shared your device correctly from the XP host.
    Regards

    Andutt

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3
    Thank you guys. I really appreciate your help. Since I am going out for a meeting next week in maine and will be busy with the preparation, I don't have time to try your solutions right now, but definitely will try after I come back and report to you the results. For "leenux_tux", I have checked the firewall before, I think I disabled the firewall in the Mandrake, there is an option in the security section, so it's not the problem. I also don't have firewall in windows itself, however, I have Zonealarm running, should I disable it?

  6. #6
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    stuff

    yes disable zone alarm for now. you can reconfigure it later. zonealarm is meant to stop network traffic so it certainly won't help.

    Remember what you're using smb / cifs. this protocol is slow. browsing lists are needed. I always set up samba as a domain server so that it maintains the WINS database and helps with computer finding. It can take up to 15 minutes for the computers to find each other without a WINS server.

    From the linux machine you can help things along using nmblookup. This does loads of different stuff. search the samba online docs for it and that will give you some starters.
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  7. #7
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3
    I tried all the methods without any success. It took me too much time and I am going to Fedora which I know it's working. I will get used to linu first then try to get different fancy things. Thank you guys however.

  8. #8
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    First try to use:

    smbclient -L //192.168.0.101

    If it ask about a password give the password/

    Second:

    Did you add users to access your shares:

    If not:

    smbpasswd -a user

    Give a password for that user.

    Third:

    Do not add root to smb

    Four:

    If you can't see shares under smbclient -L then you have to configure your samba, or you winxp.
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •