Find the answer to your Linux question:
Results 1 to 2 of 2
hi there I tried today to update my kernel so i tried to use yum command: PHP Code: [ root @ server  ~] # yum list kernel Loading  "installonlyn"  plugin Setting up repositories Reading repository metadata in from local files Excluding Packages in  ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    Smile kernel problem anyone can help?


    hi there

    I tried today to update my kernel so i tried to use yum command:

    PHP Code:
    [root@server ~]# yum list kernel
    Loading "installonlyn" plugin
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in 
    global exclude list
    Finished
    Installed Packages
    kernel
    .i586 2.6.18-1.2798.fc6 installed 
    Available Packages
    kernel
    .i586 2.6.22.9-61.fc6 updates 
    kernel
    .i686 2.6.22.9-61.fc6 updates 
    after that I rebooted the server and it gone down.

    i asked my datacenter to reboot my server and they told me the O/S is having a problem with kernel panic.

    i told them to check grub.conf and try to boot again from the old kernel, and they successed this time.

    and they told me: Right now the server is booting off the older kernel. The new kernel panics because it can't find any partitions.

    PHP Code:
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd0,0)
    # kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
    # initrd /initrd-version.img
    #boot=/dev/hda
    default=0
    timeout
    =5
    splashimage
    =(hd0,0)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora Core 
    (2.6.22.9-61.fc6)
    root (hd0,0)
    kernel /vmlinuz-2.6.22.9-61.fc6 ro root=/dev/mapper/VolGroup00-LogVo$
    initrd /initrd-2.6.22.9-61.fc6.img
    title Fedora Core 
    (2.6.18-1.2798.fc6)
    root (hd0,0
    anyone could advice me how can finish the kernel updates because really I'm still new to linux.

  2. #2
    Just Joined!
    Join Date
    Nov 2007
    Posts
    2

    Smile Try this

    your problem is you just list the kernel package but did not install the new one.

    #yum -ivh kernel.i586 2.6.22.9-61.fc6

    this will install a new kernel in. then you have to set your grub.conf file to point to this new kernel.

    wish that this will help


    your problem
    [root@server ~]# yum list kernel
    Loading "installonlyn" plugin
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Installed Packages
    kernel.i586 2.6.18-1.2798.fc6 installed
    Available Packages
    kernel.i586 2.6.22.9-61.fc6 updates
    kernel.i686 2.6.22.9-61.fc6 updates

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •