Find the answer to your Linux question:
Results 1 to 2 of 2
first of all i have to say i know NOTHING about servers just migrated my shop from mediatemple GS plan (a shared hosting) to a DV plan (virtual private/dedicated) the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    2

    Sessions directory /tmp does not exist on MediaTemple (dv) host (but it does!)


    first of all i have to say i know NOTHING about servers

    just migrated my shop from mediatemple GS plan (a shared hosting) to a DV plan (virtual private/dedicated)

    the new site is:
    Prescription Eyeglasses - EyeBuyDirect

    the server FS looks like this:

    • drwxrwxrwx --- tmp
    • ....
    • drwxr-xr-x --- usr
    • drwxr-xr-x --- var
      • tmp
      • ...
      • www
        • html
        • ...
        • vhosts
          • ...and so on...
        • ...
      • db
      • ...
      • lib



    and so on.....

    as you can see, i have a TMP folder at the FS root.
    i also have one in /var/

    i also tried to create TMP forlders everwhere (www, vhost, domainname.com / httpdocs ), always giving chmod 777
    but i always get the same error:
    "The sessions directory does not exist: /tmp"

    what am i getting wrong here?
    where should the tmp folder be placed, under such environment?
    or should i change the variable to what path?

    please help!
    i am loosing sleep on a path string :'( ,immagine when i'll have to do something serious!

    just for testing, i also tried to printout the dir structure from within php:
    Code:
    if ($handle = opendir('./')) {
    	while (false !== ($file = readdir($handle))) {
    		if ($file != "." && $file != "..") {
    			echo "$file\n";
    		}
    	}
    	closedir($handle);
    }
    but it result empty....

  2. #2
    Just Joined!
    Join Date
    Nov 2007
    Posts
    2
    by doing some testing i found out the following:

    the session file is actually created correctly under the set session.save_path ("/var/www/vhosts/mydomain.com/tmp" in my case now)

    the problem is that php is_dir() function doesnt see that path
    [is_dir('/var/www/vhosts/mydomain.com/tmp') => FALSE]
    and the session doesnt work correctly, so that a new session file is created on every page reload.

    For the records, we had this platform running on any different type of server and never had this problem (plus it's osc, quite tested...)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •