Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I have changed DirectoryRoot in httpd.conf file to my desired location, the index.html file shows up when I type "localhost" in the browser. In the index file I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! brokenwings's Avatar
    Join Date
    Nov 2007
    Location
    Finland
    Posts
    26

    Configuring httpd.conf to make Apache work


    Hello,

    I have changed DirectoryRoot in httpd.conf file to my desired location, the index.html file shows up when I type "localhost" in the browser.
    In the index file I have linked some folders (present in DirectoryRoot folder), but when I click the links, I get "Error 404, Object not found".

    Thanks in advance for any help and suggestions.

    Using Apache 2.2.6 on Mandriva 2008.0

    Regrards,

  2. #2
    Just Joined! brokenwings's Avatar
    Join Date
    Nov 2007
    Location
    Finland
    Posts
    26
    Thought that this information might be helpful for someone to understand the problem better and answer specifically.

    permissions are as follows:
    [root@server qawwalis]# ls -al
    total 108
    drwxrwxr-x 6 asad asad 4096 2007-12-02 13:51 ./
    drwx--x--x 56 asad asad 4096 2007-12-02 14:48 ../
    drwxrwxr-x 2 asad asad 32768 2007-12-02 10:27 asad_nfak/
    drwxrwxr-x 51 asad asad 4096 2007-12-01 09:21 aziz_mian/
    -rwxrwxr-x 1 asad asad 1290 2007-12-02 14:03 index.html*
    -rw-rw-r-- 1 asad asad 1288 2007-12-02 14:03 index.html~
    drwxrwxr-x 8 asad asad 4096 2007-11-03 06:19 qari_saeed_chishti/
    drwxrwxr-x 2 asad asad 20480 2007-10-09 01:05 zeeshan_nfak/

    httpd.conf is configured as follows:

    <Directory "/home/asad/qawwalis">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
    Haven't changed anything else from httpd.conf
    You can visit the link http://62.236.61.96

    Thanks.

  3. #3
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    check your apache logs

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! brokenwings's Avatar
    Join Date
    Nov 2007
    Location
    Finland
    Posts
    26
    Fixed it. There was a problem with my index.html file Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •