Find the answer to your Linux question:
Results 1 to 3 of 3
when i try to connect via ssh i get this error message: ssh_exchange_identification:Connection closed by remote host what should be wrong?i have checked the ssh config file but nothing happened. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169

    ssh config


    when i try to connect via ssh i get this error message:
    ssh_exchange_identification:Connection closed by remote host
    what should be wrong?i have checked the ssh config file but nothing happened.
    this is how my /etc/ssh/ssh_config file looks like:
    :

    # $OpenBSD: ssh_config,v 1.19 2003/08/13 08:46:31 markus Exp $

    # This is the ssh client system-wide configuration file. See
    # ssh_config(5) for more information. This file provides defaults for
    # users, and the values can be changed in per-user configuration files
    # or on the command line.

    # Configuration data is parsed as follows:
    # 1. command line options
    # 2. user-specific file
    # 3. system-wide file
    # Any configuration value is only changed the first time it is set.
    # Thus, host-specific definitions should be at the beginning of the
    # configuration file, and defaults at the end.

    # Site-wide defaults for various options

    Host *
    # ForwardAgent no
    # ForwardX11 no

    # If you do not trust your remote host (or its administrator), you
    # should not forward X11 connections to your local X11-display for
    # security reasons: Someone stealing the authentification data on the
    # remote side (the "spoofed" X-server by the remote sshd) can read your
    # keystrokes as you type, just like any other X11 client could do.
    # Set this to "no" here for global effect or in your own ~/.ssh/config
    # file if you want to have the remote X11 authentification data to
    # expire after two minutes after remote login.
    #ForwardX11Trusted no


    # RhostsRSAAuthentication no
    # RSAAuthentication yes
    # PasswordAuthentication yes
    # HostbasedAuthentication no
    # BatchMode no
    # CheckHostIP yes
    # AddressFamily any
    # ConnectTimeout 0
    # StrictHostKeyChecking ask
    # IdentityFile ~/.ssh/identity
    # IdentityFile ~/.ssh/id_rsa
    # IdentityFile ~/.ssh/id_dsa
    # Port 22
    # Protocol 2,1
    # Cipher 3des
    # Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
    # EscapeChar ~
    # GSSAPIAuthentication no
    # GSSAPICleanupCredentials no

    # Set this to 'yes' to enable support for the deprecated 'gssapi' authentication
    # mechanism to OpenSSH 3.8p1. The newer 'gssapi-with-mic' mechanism is included
    # in this release. The use of 'gssapi' is deprecated due to the presence of
    # potential man-in-the-middle attacks, which 'gssapi-with-mic' is not susceptible to.
    # GSSAPIEnableMITMAttack no
    do you see something wrong with it?
    thanks in advance!
    Linux For Ever!

  2. #2
    afm
    afm is offline
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7

    Re: ssh config

    Quote Originally Posted by stathisx
    when i try to connect via ssh i get this error message:
    ssh_exchange_identification:Connection closed by remote host
    what should be wrong?i have checked the ssh config file but nothing happened.
    Do you have access to the server logs? If so, watch out for error messages there.

    Sounds like a /etc/hosts.{allow,deny} issue to me.

  3. #3
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    ok i will look at them and post again if something goes wrong.
    thanks
    Linux For Ever!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •