Find the answer to your Linux question:
Results 1 to 2 of 2
I want to do a master-slave mysql replication in two machines. When I configure master, I get some problem.I write these lines into configuration file “my.cnf”. [mysqld] datadir=/var/lib/mysql socket=/var/lib/mysql/mysql.sock port=3306 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    1

    Mysql Replication Problem


    I want to do a master-slave mysql replication in two machines.

    When I configure master, I get some problem.I write these lines into configuration file “my.cnf”.


    [mysqld]

    datadir=/var/lib/mysql

    socket=/var/lib/mysql/mysql.sock

    port=3306


    server-id = 1
    log-bin = /var/log/mysql/mysql-bin.log
    expire-logs-days = 20
    max_binlog_size = 104857600
    binlog-do-db = testdatabase
    binlog-ignore-db = mysql,test

    [mysql.server]

    user=mysql

    basedir=/var/lib



    [mysqld_safe]

    log-error=/var/log/mysqld.log

    pid-file=/var/run/mysqld/mysqld.pid


    Then I going to start mysql service, the service is not started. But when I disable the log-bin line into my.cnf file, the service again start profile. I create a folder “mysql” in /var/log and create a mysql-bin.log file into that folder.But still got the same problem.

    My Distro: CentOS5

    How can I resolve this log-bin issue?

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    4
    What does the mysqld.log say?
    You might want to check, that mysql server user has permissions to write the binlog file to your specified location.

    rgrds,
    HS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •