Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to compile Apache 2.0.50 from source and it is failing. Here is the configure command: ./configure --enable-so --enable-ssl=shared --with-ssl=/usr/local/ssl --enable-rewrite --enable-proxy --prefix=/usr/local/apache2 This runs fun, but make ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Austin, TX
    Posts
    1

    Problems w/ Apache 2.0.50 - PCRE Error in Build


    I am trying to compile Apache 2.0.50 from source and it is failing. Here is the configure command:

    ./configure --enable-so --enable-ssl=shared --with-ssl=/usr/local/ssl --enable-rewrite --enable-proxy --prefix=/usr/local/apache2

    This runs fun, but make dies with the following output:

    pcre.c: In function 'pcre_compile':
    pcre.c:2534: 'pcre_default_tables' undeclared (first use in this function)
    ...
    make[3]: *** [pcre.lo] Error 1
    make[3]: Leaving directory '/usr/local/src/httpd-2.0.50/srclib/pcre'

    I tried removing the SSL stuff from the configure line to rule it out, and I get the same error. I am assuming pcre is needed for the rewrite module. I have searched the web and found this problem reported once or twice, but never any solution or ideas on fixing it. Any ideas?

    Regards.

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    you *may* find that installing the PCRE libary will solve the problem:
    http://www.pcre.org/

    Jason

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •