Find the answer to your Linux question:
Results 1 to 7 of 7
I have two computers. win 2k server is installed in one computer and red hat linux 9 is installed in another computer. I installed samba 3.04 on linux computer to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    5

    file sharing by using samba


    I have two computers. win 2k server is installed in one computer and red hat linux 9 is installed in another computer.

    I installed samba 3.04 on linux computer to share files. I am using webmin to configure samba and other stuff. I can see server name(linux) in "Computers near me" section on win 2k server, but when i try to access it, it says "\\frodo is not accessible. The network path was not found". i double-checked if samba is running. it's running ok.

    can anybody tell me how to do it?

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    try accessing it via its ip address to see if it is a naming issue or a connectrion one. type
    Code:
    ifconfig eth0
    (assuming that your connection on the redhat box is hardwire ethernet, otherwise adjust the name as nessicary.) to see your linux machines ip, in windows
    Code:
    ipconfig
    should do it, have them ping eachother, then open a fileamanger and try //192.168.0.__ (or whatever your ip's are)
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Did you configure samba by adding users and editing the smb.conf? It may not let you browse (don't think it does) without adding shares, users, etc. to samba.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    A suggestion:

    [EXAMPLE]
    comment = example
    path = /home/samba/example
    writable = yes
    public = yes
    guest ok = yes

    if you have the above options it should work perfectly. Maybe some other options can help, if you need other options ask.
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  6. #5
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    A suggestion:

    [EXAMPLE]
    comment = example
    path = /home/samba/example
    writable = yes
    public = yes
    guest ok = yes
    You need to put the option browseable = yes in as well if you want to browse the Linux share from Network Neighbourhood in W2K.

    In RH9 go to menu->system settings->server setting ->samba server
    Your share should be in the opening screen in configured correctly in the smb.conf file.

    Go to the preferences menu and select Samba Users. Click Add User.

    Select the appropriate Unix Username your Username maybe.
    Type in the Windows username you use.
    Then think of a samba password, this can be whatever you like.

    Now go back to Samba Server Configuration Screen. Highlight your shared path and click properties. Click the access tab. Your samba user you just created should be in the box. Click the check box. Click OK.

    Then quit the application. Reboot the samba server as su

    Code:
    /etc/init.d/smb restart
    Go back to your Win machine and select your Linux machine again. Hopefully you should get a user and password prompt. type in your Linux username and samba password. You should now be sharing files between both machines.

    Armage

  7. #6
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    Quote Originally Posted by Armage
    A suggestion:

    [EXAMPLE]
    comment = example
    path = /home/samba/example
    writable = yes
    public = yes
    guest ok = yes
    You need to put the option browseable = yes in as well if you want to browse the Linux share from Network Neighbourhood in W2K.
    I don't use browseable = yes under Linux. Never. The most of the times it work perfectly without.
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  8. #7
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    I know I use browseable = no at work to hide my machine on the network.

    hahahaha

    But, the option is there if people want the ease of selecting the shared Linux Folder from Network Neighbourhood.

    I hope the rest of the post seemed readable and useable to some.

    Armage

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •