Find the answer to your Linux question:
Results 1 to 10 of 10
Well, I am new to Postgresql and I think that the program is written as a joke by its builders to Frustrate System Administrators. I need Postgresql for a Program ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429

    Unhappy postgresql wants me to get bold or what?


    Well, I am new to Postgresql and I think that the program is written as a joke by its builders to Frustrate System Administrators.
    I need Postgresql for a Program called LedgerSMB. Its a piece of Accounting Software that runs on Perl and Postgres.
    The Installation of LedgerSMB did run fine. But well now I want to make a Database and I get the following Error Message.
    Code:
    psql:sql/Pg-database.sql:825: ERROR: language "plpgsql" does not exist
    HINT: You need to use "createlang" to load the language into the database.
    psql:sql/Pg-database.sql:828: ERROR: current transaction is aborted, commands ignored until end of transaction block
    psql:sql/Pg-database.sql:836: ERROR: current transaction is aborted, commands ignored until end of transaction block
    psql:sql/Pg-database.sql:839: ERROR: current transaction is aborted, commands ignored until end of transaction block
    psql:sql/Pg-database.sql:841: ERROR: current transaction is aborted, commands ignored until end of transaction block
    So I did read that hint and I was playing around with that for a short while.
    I did read the man page and stuff and finally I got the following line out of it:
    createlang -U ledgersmb ledgersmb <Language I want to add>
    So I did that and then I did execute:
    createlang -U ledgersmb ledgersmb -l
    MyOutput was:
    Code:
     Procedural Languages
       Name    | Trusted?
    -----------+----------
     plpgsql   | yes
     pltcl     | yes
     pltclu    | no
     plperl    | yes
     plperlu   | no
     plpythonu | no
    I dont know how stupid I am but the Error keeps comming up.
    But I see psql:sql/Pg-database.sql:825: ERROR: language "plpgsql" does not exist Still in there.
    But now it DOES exist..
    Code:
     Procedural Languages
       Name    | Trusted?
    -----------+----------
     plpgsql   | yes
     pltcl     | yes
     pltclu    | no
     plperl    | yes
     plperlu   | no
     plpythonu | no
    So Somebody told me:
    You should use PgAdmin]|[
    So I installed that. Connected to it.
    And well I cant find my Databases or ANYTHING..

    Now I wonder.
    Is there ANYONE out there who has Experience with a Working PostGresql or is postgres a Joke of its Developers..

    Is there anyone who wants to help me Id be really pleased if so.

    Or is there maybe a Translator that liserns on the Default Postgres Port and Transforms it into MySQL commands so I can use MySQL instead of Postgres...

    Thanks for any input.

    Cheers,
    Robin
    New Users, please read this..
    Google first, then ask..

  2. #2
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    PostgreSQL is actually a very robust RDBMS.

    This is actually a LedgerSMB issue. My guess is that you are running ledgersmb as a central user db, and trying to create another database. If you want to create a *new* database, enter credentials for a database superuser in the database creation screen. If you want to import into an existing database, create the language in that database.

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5

    one more point

    PostgreSQL does have a bit of a learning curve (and it is more like Oracle than like MySQL). I would *highly* recommend joining the LedgerSMB and the PostgreSQL user lists. Just reading the posts will help a lot!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    Quote Originally Posted by einhverfr View Post
    PostgreSQL is actually a very robust RDBMS.

    This is actually a LedgerSMB issue. My guess is that you are running ledgersmb as a central user db, and trying to create another database. If you want to create a *new* database, enter credentials for a database superuser in the database creation screen. If you want to import into an existing database, create the language in that database.
    well in LedgerSMB when I had to make a newdataset I had to enter both the Account informaiton.
    of my own user and of the SU.
    So, well I guess it just should work.

    Quote Originally Posted by einhverfr View Post
    I would *highly* recommend joining the LedgerSMB and the PostgreSQL user lists. Just reading the posts will help a lot!
    Well I did, but that doesnt help since they dont allow me to get on them... -.-'
    Thanks for the Advice though



    @all

    Anyone with a Idea to fix?
    All thanks for the advice and reading already.

    Cheers,
    Robin
    New Users, please read this..
    Google first, then ask..

  6. #5
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    Edit: It works!
    I had to Assign the Language to template1
    New Users, please read this..
    Google first, then ask..

  7. #6
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    LedgerSMB requires that you subscribe to the list before you post. If you are having problems with this, please email me at chris.travers@gmail.com directly and I will put you on the list.

    PostgreSQL moderates all posts which come from non-list-members and handles things extremely differently.

  8. #7
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    I did Subscribe
    ah well it works, so thats fine.
    thanks though
    New Users, please read this..
    Google first, then ask..

  9. #8
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    Just one more resource in case you find other issues:

    Both ledgersmb and postgresql have irc channels on Freenode.net.

    #ledgersmb and #postgresql respectively.

  10. #9
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    Quote Originally Posted by einhverfr View Post
    Both ledgersmb and postgresql have irc channels on Freenode.net.
    Thank you for that, but I did find that.
    The reason that I cant look there is since IRC is blocked within this company.

    The P10 Protocol has been blocked at the gate and gets Reported to the SysAdmin.

    Using SSH to get outside isnt a option. Since well I can only use Port 80 with TCP/HTTP Traffic and Port 433 with TCP/HTTPS Traffic.
    And thats if for me.
    Kinda Rubbish isnt it :/
    New Users, please read this..
    Google first, then ask..

  11. #10
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    Quote Originally Posted by RobinVossen View Post
    Thank you for that, but I did find that.
    The reason that I cant look there is since IRC is blocked within this company.

    The P10 Protocol has been blocked at the gate and gets Reported to the SysAdmin.

    Using SSH to get outside isnt a option. Since well I can only use Port 80 with TCP/HTTP Traffic and Port 433 with TCP/HTTPS Traffic.
    And thats if for me.
    Kinda Rubbish isnt it :/
    The email lists are likely to be your best option then. If you need me to manually subscribe you to the LedgerSMB lists, let me know FWIW, I am one of the founding developers of LedgerSMB.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •