Find the answer to your Linux question:
Results 1 to 4 of 4
hey ! i have ubuntu installed on my laptop at home, and usually ssh to the server at university. I want to enable x-tunneling (while ssh-ing to the server) so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3

    enable x-tunneling while ssh-ing to linux server


    hey !
    i have ubuntu installed on my laptop at home, and usually ssh to the server at university. I want to enable x-tunneling (while ssh-ing to the server) so that i can have convenient GUI windows for matlab and g-edit, etc. I do this in windows with X-Ming. can one of u guys help me enabling the xtunneling option on ubuntu ?

    I tried
    $ sudo gedit \etc\ssh\ssh_config
    and turned the X-tunnel forward option "on". and then tried ssh-ing to the server like this : ssh -x IP
    but it dosent work !!!

  2. #2
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    726
    You need to use a capital X to enable X forwarding, small x explicitly disables x forwarding.

    Let us know how you get on,

    Chris...
    To be good, you must first be bad. "Newbie" is a rank, not a slight.

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Also don't forget to restart your ssh service so the option is picked up.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3
    hey ,
    thanks guys ...
    i switched to capital X and all is fine now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •