Did I make a mistake when configuring Apache (or when configuring Linux)
I'm trying to upload a file on to my server.

The script I am using:
<FORM ENCTYPE="multipart/form-data" ACTION="_URL_" METHOD=POST>
Choose file: <INPUT NAME="userfile" TYPE="file">
<INPUT TYPE="submit" VALUE="Send"></FORM>

For "_URL_" I wrote "http://ip-address/subfolder". As a response I am getting a browser page saying: "The browser cannot open the page 'http://renki.aivo/subfolder/" because it does not find the server 'renki.aivo'".

If I give "http://ip-address" for _URL_, the index page of the www-folder is shown. In the case I remove the index page from the www-folder, I get a "404 Not Found" -message saying "The requested URL / was not found on this server."

So the server "renki.aivo" is searched for only when URL includes a subfolder.

"renki" and "aivo" are words that I wrote when configuring my Linux Sol16 -server some 3 years ago. As far as I remember, I was asked at two points to give a name of my own choice to er...something... and these are the words I chose (the two words meaning "servant" and "brain" in Finnish). Up till now these words have had no significance whatsoever. The only time I've run into them is when I ask for a folder listing. Then it says at the bottom of the browser page "Apache/1.3.27 Server at renki.aivo Port 80".

Have I done some mistake when configuring either Linux or Apache. I'm not very good at that stuff. And I have forgotten where it was I wrote those two words (it wasn't apache httpd.conf, I checked)